summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-22 13:01:26 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-22 13:01:47 +0200
commitb4b7bf578d6915570fc39d5ec71d692604af4d1c (patch)
treefc5716bb0d3bb17e6601b80a9de6d8ae0934e159
parentsci-mathematics/rstudio: fix missing slashes (diff)
downloadgentoo-b4b7bf578d6915570fc39d5ec71d692604af4d1c.tar.gz
gentoo-b4b7bf578d6915570fc39d5ec71d692604af4d1c.tar.bz2
gentoo-b4b7bf578d6915570fc39d5ec71d692604af4d1c.zip
sci-mathematics/spass: fix missing slashes
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sci-mathematics/spass/spass-3.9.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-mathematics/spass/spass-3.9.ebuild b/sci-mathematics/spass/spass-3.9.ebuild
index a32001e22b91..81289762c3d8 100644
--- a/sci-mathematics/spass/spass-3.9.ebuild
+++ b/sci-mathematics/spass/spass-3.9.ebuild
@@ -108,7 +108,7 @@ src_install() {
[[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
- SPASS_HOME="${ROOT}usr/bin"
+ SPASS_HOME="${EROOT}/usr/bin"
SPASS_VERSION="${PV}"
EOF
insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
@@ -118,10 +118,10 @@ src_install() {
pkg_postinst() {
if use isabelle; then
- if [ -f "${ROOT}etc/isabelle/components" ]; then
- if egrep "contrib/${PN}-[0-9.]*" "${ROOT}etc/isabelle/components"; then
+ if [ -f "${EROOT}/etc/isabelle/components" ]; then
+ if egrep "contrib/${PN}-[0-9.]*" "${EROOT}/etc/isabelle/components"; then
sed -e "/contrib\/${PN}-[0-9.]*/d" \
- -i "${ROOT}etc/isabelle/components"
+ -i "${EROOT}/etc/isabelle/components"
fi
cat <<- EOF >> "${ROOT}etc/isabelle/components"
contrib/${PN}-${PV}
@@ -132,13 +132,13 @@ pkg_postinst() {
pkg_postrm() {
if use isabelle; then
- if [ ! -f "${ROOT}usr/bin/SPASS" ]; then
- if [ -f "${ROOT}etc/isabelle/components" ]; then
+ if [ ! -f "${EROOT}/usr/bin/SPASS" ]; then
+ if [ -f "${EROOT}/etc/isabelle/components" ]; then
# Note: this sed should only match the version of this ebuild
# Which is what we want as we do not want to remove the line
# of a new spass being installed during an upgrade.
sed -e "/contrib\/${PN}-${PV}/d" \
- -i "${ROOT}etc/isabelle/components"
+ -i "${EROOT}/etc/isabelle/components"
fi
fi
fi