summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-04 08:11:44 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-04 08:11:57 +0200
commitb5364d97b7ab5e07e896664506f1eac92e1db041 (patch)
tree2afbc65df034dfa6bab111915c3d7f32101895da
parentdev-ruby/rails-dom-testing: add 2.2.0 (diff)
downloadgentoo-b5364d97b7ab5e07e896664506f1eac92e1db041.tar.gz
gentoo-b5364d97b7ab5e07e896664506f1eac92e1db041.tar.bz2
gentoo-b5364d97b7ab5e07e896664506f1eac92e1db041.zip
dev-ruby/addressable: add 2.8.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/addressable/Manifest1
-rw-r--r--dev-ruby/addressable/addressable-2.8.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index 5b8b7ab55383..90863734101d 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -2,3 +2,4 @@ DIST addressable-2.8.1.gem 105984 BLAKE2B 9ba6fffe2af965be57ef7b2f86c5c86c672e00
DIST addressable-2.8.2.gem 106496 BLAKE2B 701f4c298686593cadc7317fe2072474fa2a4a35c53047d650fb166db969d5a0e8eca703d2ec2ed334936711d7fe5c839dfe6f04bea5d413da22a41094d58b98 SHA512 9c5f2a5cad9f1f4ea9ec9ab30106123f922737f9dafdf5efd9b74c939e933976c37c0a9775743e7277a0850fa1676ede5520db4fe6e0a9507e5b3a2b94d9d8d7
DIST addressable-2.8.3.gem 105984 BLAKE2B 00775f119c59d3db331bfeb3bb48f26c74d938714791183a4099fc4da7c871045c12074132e6368b2a8a0c114b18e301735aa142d8ae4bc52a77f55cc3fa61a1 SHA512 dc3f0731b2ccb464473ac9005d8a68fa457b9d5f83fd60f32fa2cd741b69d0e08e89c5ea10fb4734c0bb563ef73797cfd5500b486f1daaf0e1456488ec8c2340
DIST addressable-2.8.4.gem 105984 BLAKE2B 788d84a9fe52a05c5e8429aaea59096b604bfad22b06c48f0d8186eb4197e47171310d1d3e9ab296d08b3033443d1fdf6b9b55fdefafd51e4c88feaf5b53298d SHA512 45324e96fb4415b745eb26bd0c3e042102efbdfca879177a70288303c96a4889ff59f794ed0010ea8a95c5d6907b76b0e8c66cce0a5478832c9df465a01e3fcb
+DIST addressable-2.8.5.gem 106496 BLAKE2B 07aadf72772eb909c833079918e44231208b5d9494eac218da1ed30224eb5fabb5369b5dbb0759d328f0cc57117e26fee33ec1139f75d89b2255472df9f2f9e7 SHA512 cc35437d91dfb95f49eeba60b153b89d9f1475fd0770056c22865913629f3bf0a3545585a457bc5a42d97f2e6e81362308e9eb91fd3b2b8a571b997ba53796eb
diff --git a/dev-ruby/addressable/addressable-2.8.5.ebuild b/dev-ruby/addressable/addressable-2.8.5.ebuild
new file mode 100644
index 000000000000..dbbb6d44ede0
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "|| ( dev-ruby/public_suffix:5 dev-ruby/public_suffix:4 )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}