summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-11-20 21:44:05 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-11-20 21:44:05 +0000
commitb5b5acba5c0d2b5c20f113e144a7869e27b2a536 (patch)
treef1b61fa1fcd24adddb5fac0af30ad4ad32b5b3f2
parent2018-11-20 21:04:43 UTC (diff)
parentsys-devel/autogen: bump up to 5.18.16, bug #671564 (diff)
downloadgentoo-b5b5acba5c0d2b5c20f113e144a7869e27b2a536.tar.gz
gentoo-b5b5acba5c0d2b5c20f113e144a7869e27b2a536.tar.bz2
gentoo-b5b5acba5c0d2b5c20f113e144a7869e27b2a536.zip
Merge updates from master
-rw-r--r--sys-devel/autogen/Manifest1
-rw-r--r--sys-devel/autogen/autogen-5.18.16.ebuild39
-rw-r--r--sys-devel/autogen/files/autogen-5.18.16-no-werror.patch14
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/autogen/Manifest b/sys-devel/autogen/Manifest
index c07217346bd3..0a8ed2be0e25 100644
--- a/sys-devel/autogen/Manifest
+++ b/sys-devel/autogen/Manifest
@@ -1,3 +1,4 @@
DIST autogen-5.18.10.tar.xz 1017960 BLAKE2B 3869abb5b0b97f480d4b50b205f25d54da2b9c5227c13a55e11754b5ceff4afd74576efc17a748d40762b7345e3c02c60fa38f6d20893671089e9de48b0e0240 SHA512 cfb06566aebe2aa833f2a032c513aa1d57a803eee82f03d6f6fe3806a0f570d5dbf8331015d2afde89a3d4e4c967b6a367d3e2820addb3ff6a5ac6d481a058be
DIST autogen-5.18.12.tar.xz 1018412 BLAKE2B f8ac1efbd6c6afdaa248e3063cf43fe0d32da6bd1160397f8bf736970f15047c70772a6e21d6010c8103aecce6ea2c3d90a63b9c5cbd6199a97c82384630a341 SHA512 46de5910e2786a9b0ec96989d3e11be3ed12e5600f01d6fa9291bfbfae42a66994aeca2949837b471827ae3285ec4caafb42bc19ca91146cd7ea7a355aaffd03
+DIST autogen-5.18.16.tar.xz 1046276 BLAKE2B 23f9e0948f24ada715fb2bcbbfecba768cf51d169ea3ff4724a97b18f598d2d7fb2ffa7e23919ec8dcc0e352f9d3280f3740dab279a0af1412919cf10c6cb0bf SHA512 5f12c982dbe27873f5649a96049bf019ff183c90cc0c8a9196556b0ca02e72940cd422f6d6601f68cc7d8763b1124f2765c3b1a6335fc92ba07f84b03d2a53a1
DIST autogen-5.18.4.tar.xz 1017936 BLAKE2B bc2b4d7143642baa923c49bfe37d60c0d3a0a3a09a9af504c5dc865f1054e4d510ca3144737c2098a75189a7335bc560ec26318689ebf6d1291969d5a081cfa2 SHA512 a02363484de5019bd90fb6f2cf52b1b9556d6cf310c62a68830d0b2408ea4870d3c262fe5d1c27e3586ed3af4a7487d7422ad117760ac2a01ef3cfcfc1f2bfb6
diff --git a/sys-devel/autogen/autogen-5.18.16.ebuild b/sys-devel/autogen/autogen-5.18.16.ebuild
new file mode 100644
index 000000000000..fc70a815c931
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.18.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="https://www.gnu.org/software/autogen/"
+SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libopts static-libs"
+
+RDEPEND=">=dev-scheme/guile-2.0:=
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.18.16-no-werror.patch
+)
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}
diff --git a/sys-devel/autogen/files/autogen-5.18.16-no-werror.patch b/sys-devel/autogen/files/autogen-5.18.16-no-werror.patch
new file mode 100644
index 000000000000..7f9f36428e18
--- /dev/null
+++ b/sys-devel/autogen/files/autogen-5.18.16-no-werror.patch
@@ -0,0 +1,14 @@
+--- a/configure
++++ b/configure
+@@ -18926,3 +18926,3 @@ test "X${GCC}" = Xyes && {
+ CFLAGS="$CFLAGS -Wno-format-contains-nul -fno-strict-aliasing"
+- WARN_CFLAGS="$CFLAGS "`echo -Wall -Werror -Wcast-align -Wmissing-prototypes \
++ WARN_CFLAGS="$CFLAGS "`echo -Wall -Wcast-align -Wmissing-prototypes \
+ -Wpointer-arith -Wshadow -Wstrict-prototypes -Wwrite-strings \
+--- a/configure.ac
++++ b/configure.ac
+@@ -200,3 +200,3 @@ test "X${GCC}" = Xyes && {
+ CFLAGS="$CFLAGS -Wno-format-contains-nul -fno-strict-aliasing"
+- WARN_CFLAGS="$CFLAGS "`echo -Wall -Werror -Wcast-align -Wmissing-prototypes \
++ WARN_CFLAGS="$CFLAGS "`echo -Wall -Wcast-align -Wmissing-prototypes \
+ -Wpointer-arith -Wshadow -Wstrict-prototypes -Wwrite-strings \