summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:28 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:17 +0100
commitb687a708666cc014693abb4f7a0a81604cbb8def (patch)
tree8016365429a0c811d4404432ac62a0d8b206b02a
parentdev-haskell/typed-process: add 0.2.10.1-r1 (diff)
downloadgentoo-b687a708666cc014693abb4f7a0a81604cbb8def.tar.gz
gentoo-b687a708666cc014693abb4f7a0a81604cbb8def.tar.bz2
gentoo-b687a708666cc014693abb4f7a0a81604cbb8def.zip
dev-haskell/unbounded-delays: add 0.1.1.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/unbounded-delays/Manifest1
-rw-r--r--dev-haskell/unbounded-delays/metadata.xml9
-rw-r--r--dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild24
3 files changed, 25 insertions, 9 deletions
diff --git a/dev-haskell/unbounded-delays/Manifest b/dev-haskell/unbounded-delays/Manifest
index 5215d47c606c..c5907e424d62 100644
--- a/dev-haskell/unbounded-delays/Manifest
+++ b/dev-haskell/unbounded-delays/Manifest
@@ -1 +1,2 @@
DIST unbounded-delays-0.1.1.0.tar.gz 4166 BLAKE2B 158b05e35afd4c2b8f33caeea748466ee8cb6348f4505649c442f76777b41326128b84b8b7559e06d031c1486886e99e95bf69ac7e80eb16ec1c17cc5b5354e3 SHA512 70e26055abe40b38e20bc5dadc3ae32b699613698d0fc36bbd519fe011128fbdda7e963a69f25375b4e8a26b2ebfa2cdd4496d9d045e9f19672224654e5e7948
+DIST unbounded-delays-0.1.1.1.tar.gz 4114 BLAKE2B 97ffa71675906f9eef6ae297369f9668273ffcb4cc8d9d7efb43b152b5abbeae888ca67e1f77568636feeb3eb4d1bd8549a1446a4f56c7db5ef5570a43da7c57 SHA512 7439c8976498bd84e966b7e08e8d868d65debe3ffc7fd77dc6de345258b4532f2203415abf9530fdaa5feba0bfdc1031303b343502d1f3dc401058125babd41b
diff --git a/dev-haskell/unbounded-delays/metadata.xml b/dev-haskell/unbounded-delays/metadata.xml
index cb2204836918..937381521944 100644
--- a/dev-haskell/unbounded-delays/metadata.xml
+++ b/dev-haskell/unbounded-delays/metadata.xml
@@ -5,13 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @threadDelay@ and @timeout@ functions from the @base@ library
- use the bounded @Int@ type for specifying the delay or timeout
- period. This packages provides alternatives which use the
- unbounded @Integer@ type.
- </longdescription>
- <upstream>
- <remote-id type="github">basvandijk/unbounded-delays</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild b/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild
new file mode 100644
index 000000000000..47393db2069b
--- /dev/null
+++ b/dev-haskell/unbounded-delays/unbounded-delays-0.1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Unbounded thread delays and timeouts"
+HOMEPAGE="https://github.com/basvandijk/unbounded-delays"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"