summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-08 06:45:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-08 06:45:16 +0200
commitb75fae8e1addd0cc6f40e0a05d2747e29afde3db (patch)
treee0ce3033a5ca843ffdf08da897f63bdbbbb370a1
parentapp-admin/awscli: Bump to 1.27.109 (diff)
downloadgentoo-b75fae8e1addd0cc6f40e0a05d2747e29afde3db.tar.gz
gentoo-b75fae8e1addd0cc6f40e0a05d2747e29afde3db.tar.bz2
gentoo-b75fae8e1addd0cc6f40e0a05d2747e29afde3db.zip
dev-python/beautifulsoup4: Bump to 4.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/beautifulsoup4/Manifest1
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 08547a4d4561..baefe718a0f2 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,3 +1,4 @@
DIST beautifulsoup4-4.11.2.tar.gz 517627 BLAKE2B 19fc88dff84c398461ecce3b66b1a92c3541114e3595aa1bae7182914e174d9c36b6de37ba120200695f6dca489c6afcd361244ae9577bc469d20a0864989d48 SHA512 68f5328f881946e80ed1af36b26da184f0af58aaf124f5f623f89c40130e1578f6dbe874b11c802e52c0ec02cfbf6b681e10eb235279631f479d14c2243e7dd3
DIST beautifulsoup4-4.12.0.tar.gz 523942 BLAKE2B a1cde7726cfe96327300a4c9d44fbf98e3196911be628aa7633633f3515ed6c5d2d0cea61b4a4c9529208bc2339ae070e8e5ffc60d0afec133ca81079b53a49b SHA512 8f4dcaccdcd220f9641c7080d685c1eaa9c851daa579c187fda75a1d85dcf2fe4cc673c2d4b2143682003390ef1d954366ea0d2820e07f8c10418350d31bccd3
DIST beautifulsoup4-4.12.1.tar.gz 504683 BLAKE2B a02684f0f431c7ae79118e698e985fb2312b277323bb25323c5361badc55a8b15cc9de7f2c9fbc8e5dc133e5d660692b5d1bdd546c65128d9ab56a87712cef0f SHA512 f66538e251b447e532acb5c75ec8c0af7a30a7eb4241470f0691db013ab7990a173cbe3c649f29cb58036b4ed622ee4284372fe3d091175c11baba9b15619f2d
+DIST beautifulsoup4-4.12.2.tar.gz 505113 BLAKE2B 94412a87dcffeb14655417eb61a784c8933aea79c81721ebf30114d55fd3e0f58850e0cfed354d3573d1bf18b556f3d83474b64a2a8d88f503c5125d5931321d SHA512 1dbb620f675bb319ef050ece0f343e80359bdc59cd8b8de19b1851aa5bca1081a7e953e3221ad97142198c17f67384c05b0406af24a123d71398f209fb89db97
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.2.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.2.ebuild
new file mode 100644
index 000000000000..179ee52155fd
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/soupsieve-1.3[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source