summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-11-06 17:28:57 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-11-06 17:50:04 -0500
commitb76f2dce2d9a03cf818a09aad251b349beb0b841 (patch)
tree309735caa7f6c67c83d059828e7e6bc5661191f8
parentdev-java/leiningen-bin: version bump. (diff)
downloadgentoo-b76f2dce2d9a03cf818a09aad251b349beb0b841.tar.gz
gentoo-b76f2dce2d9a03cf818a09aad251b349beb0b841.tar.bz2
gentoo-b76f2dce2d9a03cf818a09aad251b349beb0b841.zip
dev-libs/xapian: version bump to 1.4.9
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.9.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index cf986a257633..9adbfa2b693b 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -5,3 +5,4 @@ DIST xapian-core-1.4.5.tar.xz 2810612 BLAKE2B 7784e69e3ca064751d829173949fcde656
DIST xapian-core-1.4.6.tar.xz 2839964 BLAKE2B ab35e3098d8cf99656539968171073683811dc9a98b7d26e389c0cb1e8d1b70f9007e0ba61defe496713cb0f304a0fed7afa253174e900c0756084ab40721573 SHA512 f08168eba26a24ea00c2219d2cdfac1d904b51162fdd98d437564786375245e00010986a7d6e9c8c7548ae19aab80434b5cb0051252f902b40db2976b1008fe2
DIST xapian-core-1.4.7.tar.xz 2874172 BLAKE2B 917a35ca717ed4437f4a617ce0b6ac07d5936e07aac6bfa9d6878c12ed0c38e7ca994ad943b6dc7a5cd2fe131a445c5a7859f2286c2201dd048020569ce1a0bf SHA512 9e77a78bd63036966ebb9bbed91e36fef17b37c9465c8d4b7dc8041f0e24b040e6520de645babfeeade952771d145176a204328718cfa8bc2291bb6fdbe840d2
DIST xapian-core-1.4.8.tar.xz 2880432 BLAKE2B 8468a33614d8c7617755cfe4cc79e72ab42612a79be9fb684525e268efe80c42ce902a60a44dc5548c70b719d752e15927ce24b4ab457905022ae806bffb1f11 SHA512 9ed1f34ec1bf53a4dc628ebb8d080af79a4ac6a315bf1ae52441f0ac3a63e5478ed02887382116b28157b926e685fdc730489426edce560aa4bba27cb7295e48
+DIST xapian-core-1.4.9.tar.xz 2880024 BLAKE2B 25272128fbbd7cb23dab92c87be03fee8dae5b742f26a66b9c51c649a7826639e52124f5f0748d3c12cce81a7875ed217931ddbe2b04303a08709c4a773a617f SHA512 1af23815ff9358d6407723d1a7d3dc00df8f45f4808ccaa4c57f38197763fdc2d62cb7b080fab737408db42ced85707021eac881d80767248ea22aff8a2e4aa3
diff --git a/dev-libs/xapian/xapian-1.4.9.ebuild b/dev-libs/xapian/xapian-1.4.9.ebuild
new file mode 100644
index 000000000000..311fd46fc567
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}