summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-28 22:53:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-28 22:53:24 +0100
commitb8592e9f6b16a8a0d81fe960fcfe0bd032f279ec (patch)
tree0a819ff52203ec57266f3084209bb14ff7f3c74a
parentdev-python/tinyrpc: Remove old (diff)
downloadgentoo-b8592e9f6b16a8a0d81fe960fcfe0bd032f279ec.tar.gz
gentoo-b8592e9f6b16a8a0d81fe960fcfe0bd032f279ec.tar.bz2
gentoo-b8592e9f6b16a8a0d81fe960fcfe0bd032f279ec.zip
dev-python/celery: Remove old (drop to ~arch)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/celery/Manifest1
-rw-r--r--dev-python/celery/celery-4.1.0.ebuild109
2 files changed, 0 insertions, 110 deletions
diff --git a/dev-python/celery/Manifest b/dev-python/celery/Manifest
index e7419d4b6d45..3bdbcf607c3b 100644
--- a/dev-python/celery/Manifest
+++ b/dev-python/celery/Manifest
@@ -1,2 +1 @@
-DIST celery-4.1.0.tar.gz 1331689 BLAKE2B ac134d26a21bfd1172ea7a2ccc5f9934b4fdf56dccb6f840726040adf5b81ab0c675c0c93754340c0429c4eb5777a344be74415a795a9dd6654578979609cecd SHA512 5232adc43ba55d01f2b030382075750033e0c5c2abdc8308903e0cef7a465513b7765e2ae495da6555b377452ae233500530ef9d57e584a5352a54c5f4731c64
DIST celery-4.3.0.tar.gz 1434073 BLAKE2B 47d9d461a9bf3d3418a7cb37684f53cce58ef1d1bee928e74cc8b6ff8e9bfde19d99a59d7a8ef7b638efa24263d5b35f50c774fb5f81e9c693c9d3c6242015ac SHA512 6a4f99857c2b329eddb5200934b2c83bc2377b5b89ccbcfed548d8f52cff40800db7b94ea321f74e932ea4be42a546fb9b515569266435cecdbe204a0a891b2f
diff --git a/dev-python/celery/celery-4.1.0.ebuild b/dev-python/celery/celery-4.1.0.ebuild
deleted file mode 100644
index 623202a77643..000000000000
--- a/dev-python/celery/celery-4.1.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
-HOMEPAGE="http://celeryproject.org/ https://pypi.org/project/celery/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# There are a number of other optional 'extras' which overlap with those of kombu, however
-# there has been no apparent expression of interest or demand by users for them. See requires.txt
-IUSE="doc examples redis sqs test yaml"
-RESTRICT="!test? ( test )"
-
-# kombu < 4.2: #666228 (can be loosened in next bump)
-RDEPEND="
- <dev-python/kombu-4.2[${PYTHON_USEDEP}]
- >=dev-python/kombu-4.0.2[${PYTHON_USEDEP}]
- >=dev-python/billiard-3.5.0.2[${PYTHON_USEDEP}]
- <dev-python/billiard-3.6.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/vine[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/gevent[$(python_gen_usedep python2_7)]
- >=dev-python/pymongo-2.6.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
- >=dev-db/redis-2.8.0
- >=dev-python/boto-2.13.3[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/unittest2-0.5.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/sphinx_celery-1.3[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python2_7)
- )"
-
-# testsuite needs it own source
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- if use doc; then
- mkdir docs/.build || die
- emake -C docs html
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd-r2" celery
- newconfd "${FILESDIR}/celery.confd-r2" celery
-
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- newbashcomp extra/bash-completion/celery.bash ${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "zookeeper support" dev-python/kazoo
- optfeature "msgpack support" dev-python/msgpack
- #optfeature "rabbitmq support" dev-python/librabbitmq
- #optfeature "slmq support" dev-python/softlayer_messaging
- optfeature "eventlet support" dev-python/eventlet
- #optfeature "couchbase support" dev-python/couchbase
- optfeature "redis support" dev-db/redis dev-python/redis-py
- optfeature "gevent support" dev-python/gevent
- optfeature "auth support" dev-python/pyopenssl
- optfeature "pyro support" dev-python/pyro:4
- optfeature "yaml support" dev-python/pyyaml
- optfeature "memcache support" dev-python/pylibmc
- #optfeature "threads support" dev-python/threadpool
- optfeature "mongodb support" dev-python/pymongo
- optfeature "sqlalchemy support" dev-python/sqlalchemy
- optfeature "sqs support" dev-python/boto
- #optfeature "cassandra support" dev-python/pycassa
-}