summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-29 21:36:09 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-29 21:36:09 +0100
commitb8b476ca476297f8c6b2302f198913fd88771900 (patch)
treeb9d89fe22e60a6451d00c5608e6cce99d0cc137b
parentdev-ml/fieldslib: 0.15.0 bump (diff)
downloadgentoo-b8b476ca476297f8c6b2302f198913fd88771900.tar.gz
gentoo-b8b476ca476297f8c6b2302f198913fd88771900.tar.bz2
gentoo-b8b476ca476297f8c6b2302f198913fd88771900.zip
dev-ml/findlib: 1.9.3 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/findlib/Manifest1
-rw-r--r--dev-ml/findlib/findlib-1.9.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index 080ad5e1099d..b559fe7dc73d 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1,2 +1,3 @@
DIST findlib-1.8.1.tar.gz 261544 BLAKE2B acfa9d4e0d118ebbc0dd7b03da1fe5eaa994e5fec13dc54e60ba42f643d93968469a1a43fe4f832433dca6c3902e8846616fcf460c748bf037fe16cb2f93a847 SHA512 0d8e1ff21217fcc6823aab3ac71282789691e4ae8c3607703d0393468247f93e2d084bd4e2a8795b523f2c7f193521d3aae4b8122c934ebf8b58c3185a5bc9c1
DIST findlib-1.9.1.tar.gz 273012 BLAKE2B 8b51e3ca3dde04e77e225638f9d45166acf42fb1e3321aa5ce6e66fcddcfb978a301f2fa22a26172e1a8c2f8a879c5d1d10e8c984994d6b2879c21c4392955ce SHA512 83a05f3e310fa7cabb0475c5525f7a87c1b6bc2dc5e39f094cabfb5d944a826a5581844ba00ec1a48dd96184eb9de3c4d1055cdddee2b83c700a2de5a6dc6f84
+DIST findlib-1.9.3.tar.gz 264132 BLAKE2B 3779cb437c607d04ae6c7d8124270f36c9bd9baccce669f3785a9cd4a1a582302844019b69be14598ca807edecb26645d9d7b241e1d704c3f023ed039cad21f0 SHA512 27cc4ce141576bf477fb9d61a82ad65f55478740eed59fb43f43edb794140829fd2ff89ad27d8a890cfc336b54c073a06de05b31100fc7c01cacbd7d88e928ea
diff --git a/dev-ml/findlib/findlib-1.9.3.ebuild b/dev-ml/findlib/findlib-1.9.3.ebuild
new file mode 100644
index 000000000000..cee9e2b0d305
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.9.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt tk"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ if use doc; then
+ cd "${S}/doc" || die
+ dodoc QUICKSTART README DOCINFO
+ docinto html
+ dodoc -r ref-html guide-html
+ fi
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}