summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-14 14:24:34 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-14 14:26:50 +1300
commitb8d01ca7685680ae718a9327b3db1c5a3d7b439e (patch)
tree6d291eef5fef3877e3a50b61eff2232feee5950a
parentdev-util/buildbot-grid-view: Clean old version (diff)
downloadgentoo-b8d01ca7685680ae718a9327b3db1c5a3d7b439e.tar.gz
gentoo-b8d01ca7685680ae718a9327b3db1c5a3d7b439e.tar.bz2
gentoo-b8d01ca7685680ae718a9327b3db1c5a3d7b439e.zip
dev-perl/Tk: Bump to version 804.34.0
- EAPI6 - Add USE="examples" - Remove pod author tests - Enable/fix tests (inc: virtualx) - Make patches 'git am'-able. Upstream: - Remove special xOKp handling in Perl_Value - Fix freetype2 path on OSX - Fix clang/llvm strcpy/strncpy aborts on OSX Sierra - Fix Tk::NoteBook's FindMenu - Documentation fixes Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-perl/Tk/Manifest1
-rw-r--r--dev-perl/Tk/Tk-804.34.0.ebuild64
-rw-r--r--dev-perl/Tk/files/Tk-804.034-xorg.patch57
-rw-r--r--dev-perl/Tk/metadata.xml3
4 files changed, 122 insertions, 3 deletions
diff --git a/dev-perl/Tk/Manifest b/dev-perl/Tk/Manifest
index b99bda652ee5..8077e15dcf9d 100644
--- a/dev-perl/Tk/Manifest
+++ b/dev-perl/Tk/Manifest
@@ -1 +1,2 @@
DIST Tk-804.033.tar.gz 6924238 BLAKE2B 72ea4ca69a7602e3c7386254995983e6896c5d722f06e552b423df2dc9d5fc0a70bed6408cc1b797e803560b00a17223503a2807b847360721104a3edc324df2 SHA512 ea56be8246123bbc570d86a7d4f1610349cced91ad92ab740baca4c280822aac2e3acab6334bef60b10a70d5840f331fa40b507aba47a7929f44960df95f2aee
+DIST Tk-804.034.tar.gz 6937691 BLAKE2B ee676f82bc805ecb193c2fe999c3d451281a16a4bcd8072f0687859e6634d16cd1db40cc252b1540a3f7b883b4ca585d2b5ef1fa48f12cacffd72ca84693bdc4 SHA512 8d04fd902db72f80f749256453703e40c94fd009c6a196c608dd3bde4eeb99f974a154d5f52b28baa9e67f75529f0180619989c16cae28a9417b647908de04b6
diff --git a/dev-perl/Tk/Tk-804.34.0.ebuild b/dev-perl/Tk/Tk-804.34.0.ebuild
new file mode 100644
index 000000000000..edfc369512fc
--- /dev/null
+++ b/dev-perl/Tk/Tk-804.34.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SREZIC
+DIST_VERSION=804.034
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module virtualx
+
+DESCRIPTION="A Perl Module for Tk"
+
+LICENSE+=" tcltk BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ media-libs/freetype
+ >=media-libs/libpng-1.4:0
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXft"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-804.034-xorg.patch
+)
+PERL_RM_FILES=( "t/pod.t" )
+src_prepare() {
+ MAKEOPTS+=" -j1" #333049
+ myconf=( X11ROOT=${EPREFIX}/usr XFT=1 -I${EPREFIX}/usr/include/ -l${EPREFIX}/usr/$(get_libdir) )
+ mydoc="ToDo VERSIONS"
+
+ perl-module_src_prepare
+ # fix detection logic for Prefix, bug #385621
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" myConfig || die
+ # having this around breaks with perl-module and a case-IN-sensitive fs
+ rm build_ptk || die
+
+ # Remove all bundled libs, fixes #488194
+ local BUNDLED="PNG/libpng \
+ PNG/zlib \
+ JPEG/jpeg"
+
+ # Move files required for tests temporarily
+
+ mkdir -p "${T}/stash" || die "can't create temporary stash"
+ mv "${S}/JPEG/jpeg/testimg.jpg" "${T}/stash/testimg.jpg" || die "can't move testimg.jpg"
+
+ for dir in ${BUNDLED}; do
+ einfo "Removing bundled: ${dir}"
+ rm -r "${S}/${dir}" || die "Can't remove bundle"
+ # Makefile.PL can copy files to ${S}/${dir}, so recreate them back.
+ mkdir -p "${S}/${dir}" || die "Can't restore bundled dir"
+ sed -i "\#^${dir}#d" "${S}"/MANIFEST || die 'Can not remove bundled libs from MANIFEST'
+ done
+
+ # Restore test files
+ mv "${T}/stash/testimg.jpg" "${S}/JPEG/jpeg/testimg.jpg" || die "can't restore testimg.jpg"
+}
+src_test() {
+ virtx perl-module_src_test || die "src_test failed"
+}
diff --git a/dev-perl/Tk/files/Tk-804.034-xorg.patch b/dev-perl/Tk/files/Tk-804.034-xorg.patch
new file mode 100644
index 000000000000..fd9ce4185cf3
--- /dev/null
+++ b/dev-perl/Tk/files/Tk-804.034-xorg.patch
@@ -0,0 +1,57 @@
+From 14428e2e2ab517e935b6c8cd6c3bd90dba429532 Mon Sep 17 00:00:00 2001
+From: Michael Cummings <mcummings@gentoo.org>
+Date: Wed, 14 Jun 2006 15:06:45 +1200
+Subject: Modify build for users that didnt install xorg meta
+
+And fix finding X11 headers
+
+Bug: https://bugs.gentoo.org/128326
+Bug: https://bugs.gentoo.org/198977
+---
+ myConfig | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/myConfig b/myConfig
+index 6260866b..6b5f3ddd 100755
+--- a/myConfig
++++ b/myConfig
+@@ -316,7 +316,7 @@ if ($win_arch eq 'x') {
+ }
+ close(XMKMF);
+ while (defined $uidir) {
+- last unless ($uidir =~ s!^.*-I(\S+)/lib/X11/config!!o);
++ last unless ($uidir =~ s!^.*-I(\S+)/lib(64)/X11/config!!o);
+ $try = $1;
+ $try =~ s/'x11root'/$ENV{X11ROOT}/;
+ push(@xdirs,$try);
+@@ -365,8 +365,7 @@ if ($win_arch eq 'x') {
+ #
+ unless (defined $xlib)
+ {
+- $xlib = &lX11(0,chooseX11(</usr/X11*/lib>),chooseX11(</usr/lib/X11*>),</usr/Xfree*/lib>,'/usr/X386/lib',
+- '/opt/X11/lib')
++ $xlib = &lX11(0,chooseX11(</usr/X11*/lib>),chooseX11(</usr/lib/X11*>),</usr/Xfree*/lib>,'/usr/X386/lib','/opt/X11/lib','/usr/lib64')
+ }
+
+ #
+@@ -385,7 +384,7 @@ if ($win_arch eq 'x') {
+ exit 0;
+ }
+
+- ($base) = $xlib =~ m#-L(.*)(?:/lib)$#x;
++ ($base) = $xlib =~ m#-L(.*)(?:/lib(64))$#x;
+ if (defined $X11INC)
+ {
+ $xinc = &IX11("$X11INC");
+@@ -397,6 +396,8 @@ if ($win_arch eq 'x') {
+ {
+ warn "Cannot find X include files via $base/include\n";
+ $xinc = &IX11(map("$_/include",@xdirs),
++ chooseX11(</usr/include/X11*>),
++ '/usr/include',
+ '/usr/openwin/include',
+ chooseX11(</usr/X11*/include>),
+ chooseX11(</usr/include/X11*>),
+--
+2.16.2
+
diff --git a/dev-perl/Tk/metadata.xml b/dev-perl/Tk/metadata.xml
index 71bef34370ba..f88353dcea16 100644
--- a/dev-perl/Tk/metadata.xml
+++ b/dev-perl/Tk/metadata.xml
@@ -8,9 +8,6 @@
<upstream>
<remote-id type="cpan">Tk</remote-id>
<remote-id type="cpan-module">Tie::Watch</remote-id>
- <remote-id type="cpan-module">Tie::Watch::Array</remote-id>
- <remote-id type="cpan-module">Tie::Watch::Hash</remote-id>
- <remote-id type="cpan-module">Tie::Watch::Scalar</remote-id>
<remote-id type="cpan-module">Tk</remote-id>
<remote-id type="cpan-module">Tk::Adjuster</remote-id>
<remote-id type="cpan-module">Tk::Adjuster::Item</remote-id>