summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-07 01:42:10 -0500
committerSam James <sam@gentoo.org>2024-02-07 19:20:02 +0000
commitb8f392cabe18502df35c89b4baacf0115bd3c9d0 (patch)
tree660a2a12b40c0546a8a2e6ecf5fedf92813519c1
parentsys-fs/e2fsprogs: remove usr-ldscript support (diff)
downloadgentoo-b8f392cabe18502df35c89b4baacf0115bd3c9d0.tar.gz
gentoo-b8f392cabe18502df35c89b4baacf0115bd3c9d0.tar.bz2
gentoo-b8f392cabe18502df35c89b4baacf0115bd3c9d0.zip
sys-fs/e2fsprogs: drop old
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/e2fsprogs/Manifest2
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.5-r4.ebuild166
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.6.ebuild169
3 files changed, 0 insertions, 337 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index 3f9989d0bf4d..5e61ba790588 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -1,3 +1 @@
-DIST e2fsprogs-1.46.5.tar.xz 7040672 BLAKE2B 8d8c02e891c464782a7cff518c41d793fc73366b57e17d80ffc5afd96e6144e354290e667e9710509a9dde4e5dab7e7185c5bf084c5bfd26219f05e5e92e0830 SHA512 53282e1c524f62a95012b1aceef296d494f5238c82c9b08b29fbe6a803dbf7ccfdcd9124eb2f11fe2ff9de26387c78751a92c3217ca414f6db6242098a72d3fa
-DIST e2fsprogs-1.46.6.tar.xz 7051160 BLAKE2B 683274bf9468a3aaf41e542f22266482e75522b1fd2a255c6d852a28b08f027918d4f09239259d443a243c41eae49b3c27454f7d140da2c361c36a71ff77dcf6 SHA512 aca5ef77e36885ce9ce2995d9fae5d278c33e276e74f2a73977380f3e1cf1b3bd115fe6199e44a2f79a2827ba985b5554b8d898e88b7d04387fbba659a08e771
DIST e2fsprogs-1.47.0.tar.xz 7059372 BLAKE2B 84f58b05a9f0e14e1a66c6e5171ff23b022f51c4e9a02d4d6d1d26c91909f3c7ec9c9f0462663a4457b4479043774502b8891f691e58a61f4ef6bf9ba33f33aa SHA512 0e6d64c565b455becb84166b6a5c7090724bac5cfe69098657a31bf0481b4e2cace3de1363121b7d84820fbae85b7c83ac5f2a2b02bb36280f0e3ae83a934cec
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.5-r4.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.5-r4.ebuild
deleted file mode 100644
index 2dc05ea69a5a..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.5-r4.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic systemd toolchain-funcs udev usr-ldscript multilib-minimal
-
-DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cron fuse nls static-libs test +tools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !sys-libs/${PN}-libs
- cron? ( sys-fs/lvm2[lvm] )
- fuse? ( sys-fs/fuse:0 )
- nls? ( virtual/libintl )
- tools? ( sys-apps/util-linux )"
-# For testing lib/ext2fs, lib/support/libsupport.a is required, which
-# unconditionally includes '<blkid/blkid.h>' from sys-apps/util-linux.
-DEPEND="
- ${RDEPEND}
- test? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )"
-BDEPEND="
- virtual/pkgconfig
- sys-apps/texinfo
- nls? ( sys-devel/gettext )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
-
- # Upstream patches (can usually removed with next version bump)
- "${FILESDIR}"/${P}-parallel-make.patch
-)
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/ext2fs/ext2_types.h
-)
-
-src_prepare() {
- default
-
- cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
-
- # Get rid of doc -- we don't use them. This also prevents a sandbox
- # violation due to mktexfmt invocation
- rm -r doc || die "Failed to remove doc dir"
-
- # prevent included intl cruft from building #81096
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- MCONFIG.in || die 'intl cruft'
-}
-
-multilib_src_configure() {
- # Keep the package from doing silly things #261411
- export VARTEXFONTS="${T}/fonts"
-
- # needs open64() prototypes and friends
- append-cppflags -D_GNU_SOURCE
-
- local myeconfargs=(
- --with-root-prefix="${EPREFIX}"
- $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
- --enable-symlink-install
- --enable-elf-shlibs
- $(tc-has-tls || echo --disable-tls)
- $(multilib_native_use_enable fuse fuse2fs)
- $(use_enable nls)
- $(multilib_native_use_enable tools e2initrd-helper)
- --disable-fsck
- --disable-uuidd
- --disable-lto
- --with-pthread
- )
-
- # we use blkid/uuid from util-linux now
- if use kernel_linux ; then
- export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
- myeconfargs+=( --disable-lib{blkid,uuid} )
- fi
-
- ac_cv_path_LDCONFIG=: \
- ECONF_SOURCE="${S}" \
- CC="$(tc-getCC)" \
- BUILD_CC="$(tc-getBUILD_CC)" \
- BUILD_LD="$(tc-getBUILD_LD)" \
- econf "${myeconfargs[@]}"
-
- if grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi && use tools ; then
- emake V=1
- else
- emake -C lib/et V=1
- emake -C lib/ss V=1
- emake -C lib/ext2fs V=1
- emake -C lib/e2p V=1
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi && use tools ; then
- emake V=1 check
- else
- # required by lib/ext2fs's check target
- emake -C lib/support V=1
-
- # For non-native, there's no binaries to test. Just libraries.
- emake -C lib/et V=1 check
- emake -C lib/ss V=1 check
- emake -C lib/ext2fs V=1 check
- emake -C lib/e2p V=1 check
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use tools ; then
- emake STRIP=':' V=1 DESTDIR="${D}" install
- else
- emake -C lib/et V=1 DESTDIR="${D}" install
- emake -C lib/ss V=1 DESTDIR="${D}" install
- emake -C lib/ext2fs V=1 DESTDIR="${D}" install
- emake -C lib/e2p V=1 DESTDIR="${D}" install
- fi
-
- # Move shared libraries to /lib/, install static libraries to
- # /usr/lib/, and install linker scripts to /usr/lib/.
- gen_usr_ldscript -a com_err ss ext2fs e2p
-
- # configure doesn't have an option to disable static libs :/
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use tools ; then
- insinto /etc
- doins "${FILESDIR}"/e2fsck.conf
- fi
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.6.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.6.ebuild
deleted file mode 100644
index 0525653700ff..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.6.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic multilib-minimal systemd toolchain-funcs udev usr-ldscript
-
-DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cron fuse nls static-libs test +tools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !sys-libs/${PN}-libs
- cron? ( sys-fs/lvm2[lvm] )
- fuse? ( sys-fs/fuse:0 )
- nls? ( virtual/libintl )
- tools? ( sys-apps/util-linux )
-"
-# For testing lib/ext2fs, lib/support/libsupport.a is required, which
-# unconditionally includes '<blkid/blkid.h>' from sys-apps/util-linux.
-DEPEND="
- ${RDEPEND}
- test? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )
-"
-BDEPEND="
- sys-apps/texinfo
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch # bug #516854
-
- # Upstream patches (can usually removed with next version bump)
-)
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/ext2fs/ext2_types.h
-)
-
-src_prepare() {
- default
-
- cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
-
- # Get rid of doc -- we don't use them. This also prevents a sandbox
- # violation due to mktexfmt invocation
- rm -r doc || die "Failed to remove doc dir"
-
- # Prevent included intl cruft from building, bug #81096
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- MCONFIG.in || die 'intl cruft'
-}
-
-multilib_src_configure() {
- # Keep the package from doing silly things, bug #261411
- export VARTEXFONTS="${T}/fonts"
-
- # Needs open64() prototypes and friends
- append-cppflags -D_GNU_SOURCE
-
- local myeconfargs=(
- --with-root-prefix="${EPREFIX}"
- $(use_with cron crond-dir "${EPREFIX}/etc/cron.d")
- --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
- --with-udev-rules-dir="${EPREFIX}$(get_udevdir)/rules.d"
- --enable-symlink-install
- --enable-elf-shlibs
- $(tc-has-tls || echo --disable-tls)
- $(multilib_native_use_enable fuse fuse2fs)
- $(use_enable nls)
- $(multilib_native_use_enable tools e2initrd-helper)
- --disable-fsck
- --disable-uuidd
- --disable-lto
- --disable-largefile # need to check effect on ABI
- --with-pthread
- )
-
- # We use blkid/uuid from util-linux now
- if use kernel_linux ; then
- export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
- myeconfargs+=( --disable-lib{blkid,uuid} )
- fi
-
- ac_cv_path_LDCONFIG=: \
- ECONF_SOURCE="${S}" \
- CC="$(tc-getCC)" \
- BUILD_CC="$(tc-getBUILD_CC)" \
- BUILD_LD="$(tc-getBUILD_LD)" \
- econf "${myeconfargs[@]}"
-
- if grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to https://bugs.gentoo.org/81096"
- die "Preventing included intl cruft from building"
- fi
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi && use tools ; then
- emake V=1
- else
- emake -C lib/et V=1
- emake -C lib/ss V=1
- emake -C lib/ext2fs V=1
- emake -C lib/e2p V=1
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi && use tools ; then
- emake V=1 check
- else
- # Required by lib/ext2fs's check target
- emake -C lib/support V=1
-
- # For non-native, there's no binaries to test. Just libraries.
- emake -C lib/et V=1 check
- emake -C lib/ss V=1 check
- emake -C lib/ext2fs V=1 check
- emake -C lib/e2p V=1 check
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use tools ; then
- emake STRIP=':' V=1 DESTDIR="${D}" install
- else
- emake -C lib/et V=1 DESTDIR="${D}" install
- emake -C lib/ss V=1 DESTDIR="${D}" install
- emake -C lib/ext2fs V=1 DESTDIR="${D}" install
- emake -C lib/e2p V=1 DESTDIR="${D}" install
- fi
-
- # Move shared libraries to /lib/, install static libraries to
- # /usr/lib/, and install linker scripts to /usr/lib/.
- gen_usr_ldscript -a com_err ss ext2fs e2p
-
- # configure doesn't have an option to disable static libs
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use tools ; then
- insinto /etc
- doins "${FILESDIR}"/e2fsck.conf
- fi
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}