summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:16:35 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:22:38 +0200
commitb90b336074a406605ae17598a488df3546f27a1f (patch)
treeb8868adbdbd6273b619f7c3bba67b6399d4bf3dc
parentdev-python/spyder-line-profiler: re-add package, add 0.3.1 (diff)
downloadgentoo-b90b336074a406605ae17598a488df3546f27a1f.tar.gz
gentoo-b90b336074a406605ae17598a488df3546f27a1f.tar.bz2
gentoo-b90b336074a406605ae17598a488df3546f27a1f.zip
dev-python/spyder-vim: re-add package, add 0_pre20220831
This reverts commit 29e48581d6f949e68d464105cf216ae314c3ac81. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/spyder-vim/Manifest1
-rw-r--r--dev-python/spyder-vim/metadata.xml9
-rw-r--r--dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild40
-rw-r--r--profiles/arch/amd64/x32/package.mask1
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/spyder-vim/Manifest b/dev-python/spyder-vim/Manifest
new file mode 100644
index 000000000000..483db2d30035
--- /dev/null
+++ b/dev-python/spyder-vim/Manifest
@@ -0,0 +1 @@
+DIST spyder-vim-0_pre20220831.gh.tar.gz 293646 BLAKE2B 19c7ed461f924c441da3454d510e5782b66139de41febd2cbb5968a0f00a63a0751e7206328d73287dc9c64cdc22d9e4a5936a312b7775d55e95b68c26d270d8 SHA512 a55f41dca60c6ab6046d13d8a1baa8b8f565542c4d02bfdd931ad1daaaedae372853baa65374f553a6e73d22c234e753375936cf4be18dc4f0d342507e479031
diff --git a/dev-python/spyder-vim/metadata.xml b/dev-python/spyder-vim/metadata.xml
new file mode 100644
index 000000000000..8bb03f453618
--- /dev/null
+++ b/dev-python/spyder-vim/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild b/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild
new file mode 100644
index 000000000000..546c6239f557
--- /dev/null
+++ b/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+COMMIT="2ccf0d1e6ccaba24bd05b379065ba43bd935c7bf"
+
+DESCRIPTION="Plugin for Spyder to enable Vim keybindings"
+HOMEPAGE="https://github.com/spyder-ide/spyder-vim"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/spyder-5.3.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ "
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.rst" "doc/example.gif" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}
diff --git a/profiles/arch/amd64/x32/package.mask b/profiles/arch/amd64/x32/package.mask
index 143e490dc563..bcdeff8049ce 100644
--- a/profiles/arch/amd64/x32/package.mask
+++ b/profiles/arch/amd64/x32/package.mask
@@ -56,6 +56,7 @@ dev-python/spyder
dev-python/spyder-terminal
dev-python/spyder-unittest
dev-python/spyder-line-profiler
+dev-python/spyder-vim
dev-util/kdevelop:5
dev-util/kdevelop-php:5
dev-util/kdevelop-python:5