summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-07 13:02:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-07 13:29:53 +0100
commitb9cb19fffbd67624f1e6ecdf8e501ecc1919812f (patch)
tree2863ac2777355e9396510e700658a0c147f3b653
parentdev-python/sqlglot: Bump to 20.0.0 (diff)
downloadgentoo-b9cb19fffbd67624f1e6ecdf8e501ecc1919812f.tar.gz
gentoo-b9cb19fffbd67624f1e6ecdf8e501ecc1919812f.tar.bz2
gentoo-b9cb19fffbd67624f1e6ecdf8e501ecc1919812f.zip
dev-python/yappi: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.6.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index 79b57165e0c0..0c19f9340cf2 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1,2 +1,3 @@
DIST yappi-1.4.0.gh.tar.gz 938290 BLAKE2B 98a9c82d101e64f70f589b51ee461e1967c0fada75ab98e0de8f0446254e7ad73e25b842c85464953b9f81fc54d2007151dfc91e4176068a7cb320176c8828d2 SHA512 c557c67cfce29db1a526a2d385af28cd241eae46a653e9b4f7308a6f52ff1ede49b9211af09889c63eae3eeb38d55813a8026161b1184fccf4db4add8a022541
DIST yappi-1.5.1.gh.tar.gz 938445 BLAKE2B 38b3a4be577ff9390e71b17abda382d59c22d19a3bc36d913c67e5fe2707a2059dbcd479f217672115ab739b0a2d71d9b9700645ed6edc13c67429d4243f6c3f SHA512 ff60a6b1c1273c8e04fe9a762314ccd3a2bb66a0271e887ba2017f6df7c988bda01ee0eb6b1b68952f2244f3ebb5fe9c0f560d7823875fbea7a8e0257bb1c7c8
+DIST yappi-1.6.0.gh.tar.gz 938098 BLAKE2B 7d5ad3066647419502ce43a2577509dbfc2ba898a8a68187a0e2efa2868764139c5a0bde873eb270f4acbb98749ee770e0cd00d24079318ab291dd5becc7a00e SHA512 d6b9e30129d83ab24ac80732e6a31e7dcc9e7e0f8bedc39cd578b73b12007c38db6c5b101e4364d3d129ba24bb0adaae71bc48827ac577c8ef96c9a557a9d80f
diff --git a/dev-python/yappi/yappi-1.6.0.ebuild b/dev-python/yappi/yappi-1.6.0.ebuild
new file mode 100644
index 000000000000..569d375e0171
--- /dev/null
+++ b/dev-python/yappi/yappi-1.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}