summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2023-06-11 12:40:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-06-18 15:08:15 +0300
commitba7638a1ffaf33545db1a4ac0021a1bf80a8d869 (patch)
treec0a4fa8056d3b5297a93f96f5a9d961f1c0ae524
parentdev-ruby/rails: add 7.0.5 (diff)
downloadgentoo-ba7638a1ffaf33545db1a4ac0021a1bf80a8d869.tar.gz
gentoo-ba7638a1ffaf33545db1a4ac0021a1bf80a8d869.tar.bz2
gentoo-ba7638a1ffaf33545db1a4ac0021a1bf80a8d869.zip
app-admin/passwordsafe: add 1.17.0
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/31383 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-admin/passwordsafe/Manifest1
-rw-r--r--app-admin/passwordsafe/passwordsafe-1.17.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/passwordsafe/Manifest b/app-admin/passwordsafe/Manifest
index 3aa4d1c4e931..59d05c9d28aa 100644
--- a/app-admin/passwordsafe/Manifest
+++ b/app-admin/passwordsafe/Manifest
@@ -1,2 +1,3 @@
DIST passwordsafe-1.15.0.tar.gz 15354159 BLAKE2B 699f80325884cba9bc6e5ffb33bea5c0b2c01f12ed7e4ea1226c4a64c761a8f20b8272e771261ca59aeeb49bfaa4ea83edc9af6c0aa9ae853e537b0f76f28aaa SHA512 803572afc479d608899e1166ef032a2a660fce122e03f89f59f8e9da9f7439e0eb1d602f77283200626f49d7e146e82edf8edee40060ff4cf6163e81bdf5f738
DIST passwordsafe-1.16.0.tar.gz 15369804 BLAKE2B 344e77f74e588f41ba3696f5ea05cf054fca9f285437294033284561cbb83c76dc1311033b78673db0049132b7c9f37493c3698bb3b66e8e0a91ae63f7a83cdf SHA512 839de5072d6c9ec8fb82456e4516e51408be271ac8041b6dd9cf30990ac88914a139d96b40ee09764892acd8320abb2950d7f159a5b18c3d1549e58b922aa024
+DIST passwordsafe-1.17.0.tar.gz 15463920 BLAKE2B e64c73139c829b16b5f825d3c078f1cb3285cb15400be988e35b64e4ce701a5241e099a09092a576e487f709464b6fa5d5911f5f68e096d194329cd0214ac8cd SHA512 de1ef537c2f6c17e35d93a53cf46e86b7c1f1a4439282f8c2b98443845e3d381e113448acd739fc6ccdb5eee8ff7ebfd8c0e4306cda517ab623eaf5b9354d39d
diff --git a/app-admin/passwordsafe/passwordsafe-1.17.0.ebuild b/app-admin/passwordsafe/passwordsafe-1.17.0.ebuild
new file mode 100644
index 000000000000..fbe1137b16da
--- /dev/null
+++ b/app-admin/passwordsafe/passwordsafe-1.17.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit cmake desktop optfeature wxwidgets xdg
+
+MY_PV="${PV/_beta/BETA}"
+DESCRIPTION="Password manager with wxGTK based frontend"
+HOMEPAGE="https://pwsafe.org/ https://github.com/pwsafe/pwsafe/"
+SRC_URI="https://github.com/pwsafe/pwsafe/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/pwsafe-${MY_PV}"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="qr test +xml yubikey"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-misc/curl
+ sys-apps/util-linux
+ x11-libs/libXt
+ x11-libs/libXtst
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ qr? ( media-gfx/qrencode )
+ xml? ( dev-libs/xerces-c )
+ yubikey? ( sys-auth/ykpers )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-arch/zip
+ dev-lang/perl
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ setup-wxwidgets
+
+ local mycmakeargs=(
+ -DNO_QR=$(usex !qr)
+ -DNO_GTEST=$(usex !test)
+ -DGTEST_BUILD=OFF
+ -DXML_XERCESC=$(usex xml)
+ -DNO_YUBI=$(usex !yubikey)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ dobin pwsafe
+ dobin cli/pwsafe-cli
+ dosym pwsafe /usr/bin/${PN}
+ dosym pwsafe-cli /usr/bin/${PN}-cli
+
+ insinto /usr/share/locale
+ doins -r src/ui/wxWidgets/I18N/mos/*
+
+ insinto /usr/share/${PN}/help
+ doins help/*.zip
+
+ popd || die
+
+ newman docs/pwsafe.1 ${PN}.1
+
+ dodoc README.md README.LINUX.* SECURITY.md docs/{ReleaseNotes.md,ChangeLog.txt}
+
+ insinto /usr/share/${PN}
+ doins -r xml
+
+ doicon -s 48 install/graphics/pwsafe.png
+ newmenu install/desktop/pwsafe.desktop ${PN}.desktop
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ optfeature "on-screen keyboard for password entry" x11-misc/xvkbd
+}