summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-11-20 09:46:31 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-11-20 09:46:42 +0100
commitbac6bfca197ceb50d2246f4d829c11ba9f703cec (patch)
tree03ff7519578bffc3e8762441475e73b7e3e7de52
parentsys-apps/systemd: Stabilize 249.6 amd64, #823593 (diff)
downloadgentoo-bac6bfca197ceb50d2246f4d829c11ba9f703cec.tar.gz
gentoo-bac6bfca197ceb50d2246f4d829c11ba9f703cec.tar.bz2
gentoo-bac6bfca197ceb50d2246f4d829c11ba9f703cec.zip
media-libs/stk: bump to 4.6.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-libs/stk/Manifest1
-rw-r--r--media-libs/stk/stk-4.6.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/stk/Manifest b/media-libs/stk/Manifest
index a651b7254ec9..c0b3d102f89a 100644
--- a/media-libs/stk/Manifest
+++ b/media-libs/stk/Manifest
@@ -1 +1,2 @@
DIST stk-4.6.1.tar.gz 2593348 BLAKE2B 2cb269b8fb5732d55a394d5b8842c380b6a3e82e7338e972c6d22baf5ba1edee3f03ed699b9950d4a92a7ae3102bbb54f844ffd728c6478ebfb36328a1b89f2a SHA512 2a22078cdb630f7c014a5ab38070fd6a6d1e9aa719401e3190a040cb06b61003cd3095fe1a8890eff59e4fc42594fe893b4c0a8327175e1701c75de7537e1830
+DIST stk-4.6.2.tar.gz 2618125 BLAKE2B 8673cabbc57c5b520af62def967bf3923a91c7b619bd29faaebaa4e3fa6aabcd9dc43e605663d8062650b105ae60ebefc44a3fa420ef711119861ce03e77f130 SHA512 35a7f559cca5c9b5998528a566ae27bace3cac56cefda7ae54c06179f5002d2906c6ede6274bf06100dd6aa9dc0d1459bb8fca4a2072c686c2abfd493b6f2f3c
diff --git a/media-libs/stk/stk-4.6.2.ebuild b/media-libs/stk/stk-4.6.2.ebuild
new file mode 100644
index 000000000000..725704b60639
--- /dev/null
+++ b/media-libs/stk/stk-4.6.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Synthesis ToolKit in C++"
+HOMEPAGE="https://ccrma.stanford.edu/software/stk/"
+SRC_URI="https://ccrma.stanford.edu/software/stk/release/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug doc jack oss static-libs"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.1"
+)
+
+HTML_DOCS=(
+ doc/html/.
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #breaks with --disable-foo...uses as --enable-foo
+ local myconf
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ fi
+ if use oss; then
+ myconf="${myconf} --with-oss"
+ fi
+ if use alsa; then
+ myconf="${myconf} --with-alsa"
+ fi
+ if use jack; then
+ myconf="${myconf} --with-jack"
+ fi
+
+ econf ${myconf} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ RAWWAVE_PATH=/usr/share/stk/rawwaves/
+}
+
+src_install() {
+ dodoc README.md
+
+ # install the lib
+ dolib.so src/libstk*
+ use static-libs && dolib.a src/libstk*
+
+ # install headers
+ insinto /usr/include/stk
+ doins include/*.h
+
+ # install rawwaves
+ insinto /usr/share/stk/rawwaves
+ doins rawwaves/*.raw
+
+ # install docs
+ if use doc; then
+ einstalldocs
+ fi
+}