summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-01-06 19:19:13 +0200
committerMart Raudsepp <leio@gentoo.org>2024-01-06 20:48:06 +0200
commitbb47648a340bfdae8f98848eaa5a82c403c40fb9 (patch)
tree039a31b02b397d3993bdb5141c6f7678ea86e064
parentsci-mathematics/z3: Stabilize 4.12.4 amd64, #921493 (diff)
downloadgentoo-bb47648a340bfdae8f98848eaa5a82c403c40fb9.tar.gz
gentoo-bb47648a340bfdae8f98848eaa5a82c403c40fb9.tar.bz2
gentoo-bb47648a340bfdae8f98848eaa5a82c403c40fb9.zip
app-accessibility/orca: add 45.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-45.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index b5c4ede72462..233527c4b2fa 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,4 @@
DIST orca-44.1.tar.xz 3760772 BLAKE2B 1e2825e9183b86563d85f106f80b7fa84d7d0cc06c818cb72c2a307c9c85a421cbbfc581df7829afde558ddf468bc048382d059ae995661a5163d390585961b4 SHA512 951a60b7efd9b61762404c20b62d476c1ebc3fc2662c0be1feef307fa1761feb5195c89ce725db1585dde4c39d96e1aa74c2b5c934115a3c2669880c3c7ac200
DIST orca-45.0.tar.xz 3949908 BLAKE2B 135dff79cda2a1a116256f2c1b68a40d29b17e5507fd3407d61dfc2478339aab1d7627c3aaac5f388a0140008e8a492820f0e56caac7ea83216c50f4f3fa32d8 SHA512 3213d5f0b8e0eacc5daad3df3e521548c5e6dd5ad8584e50d60a7fd054fee86793e956d3db3dcdc223d34d72bcfbfa0b436bc40f6e965528eafa2abf36259c83
DIST orca-45.1.tar.xz 3966196 BLAKE2B 5d78e228c480e880ca62f5e6b35d5394cbe41b67dc14f7158ca3dcadcd9721bb6e37f2054c1fa3375019351fc609d1ab4268becede10b60fbc67051c5e67539f SHA512 581126ced85943c916d9b2c0a55c12fe16344c9d6501be0290698c0668909faab4c1f539ffd856c82d0b386cfa8ca00ba5176ff5b9c5c1176cc30faededb411a
+DIST orca-45.2.tar.xz 3997024 BLAKE2B dfdf113694127323a92450b04b20fcc5655be0236c0173167d5d15478703b676c3fd8c1de0e75783875c5d2d40541c764fb002314d66c7570475cd63f6bfa473 SHA512 57eee451cf0da52e1297beae6c6d527886721b23c3415a5e046f3431876fdf1603dbd81ca763ed614ace68e7db96d90b413c663f113d0033ec1f2797df7bf589
diff --git a/app-accessibility/orca/orca-45.2.ebuild b/app-accessibility/orca/orca-45.2.ebuild
new file mode 100644
index 000000000000..d7f00e9e25f3
--- /dev/null
+++ b/app-accessibility/orca/orca-45.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.48:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}