summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-11-03 10:41:41 -0300
committerMart Raudsepp <leio@gentoo.org>2023-11-04 22:20:10 +0200
commitbb5cd9bc091db7bffd5fd4b6b23c0383944a14b3 (patch)
treea34ce6402868de706c6f81cdf715a9523f0f7474
parentgnome-extra/libgsf: update LICENSE (diff)
downloadgentoo-bb5cd9bc091db7bffd5fd4b6b23c0383944a14b3.tar.gz
gentoo-bb5cd9bc091db7bffd5fd4b6b23c0383944a14b3.tar.bz2
gentoo-bb5cd9bc091db7bffd5fd4b6b23c0383944a14b3.zip
x11-libs/goffice: Version bump to 1.12.56
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.56.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 7afa46552b54..81175304f158 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1 +1,2 @@
DIST goffice-0.10.55.tar.xz 2455576 BLAKE2B 6a1a4670293e0d91c456b3ec162f92f373eeea218d4b4268ae4809b8157cefa4f3d89f3f8555ee2fd3db84fb5adcd0e4119f0e2f6c79cbd4e86d27a46c9ea726 SHA512 c49eec867e4147102b54b70847b495cad0e55fcb069c78a8374760121219b9097c1dfb5601b240e92ed68a6fb785ab5e771f7c579dd138e106ee25a1b9ddfe99
+DIST goffice-0.10.56.tar.xz 2495240 BLAKE2B 3b6956a7fda37caf679e085faa8d34821c132e6e8cc12cb859cf03e5c8a99afbeb7952b0fcf5b184df8cb6225fe99828ee1f24d5360f480ce793a5d8de44bedb SHA512 5088a14057738452effa76920c7e0bfe9a45bae2f798f18f035225738c1da2fd79a0c6e84bb83507108b5438160a839fa26d792a877da37b1cf416c3af85ed9d
diff --git a/x11-libs/goffice/goffice-0.10.56.ebuild b/x11-libs/goffice/goffice-0.10.56.ebuild
new file mode 100644
index 000000000000..9e1f7c7809f9
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.56.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg(+)]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ find "${ED}" -name '*.la' -delete || die
+}