summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 12:35:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 14:16:04 +0100
commitbc997e1fe5c259b699bb9b137f42c8be63dd9313 (patch)
tree6ca0ada0397df1a33c3408688ac764404b3ada46
parentapp-arch/unarj: Port to EAPI 6 (diff)
downloadgentoo-bc997e1fe5c259b699bb9b137f42c8be63dd9313.tar.gz
gentoo-bc997e1fe5c259b699bb9b137f42c8be63dd9313.tar.bz2
gentoo-bc997e1fe5c259b699bb9b137f42c8be63dd9313.zip
app-arch/afio: [QA] Minor touchups
Bug: https://bugs.gentoo.org/429360 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-arch/afio/afio-2.5.1-r1.ebuild9
-rw-r--r--app-arch/afio/files/afio-2.5.1-fix-build-system.patch22
-rw-r--r--app-arch/afio/metadata.xml12
3 files changed, 32 insertions, 11 deletions
diff --git a/app-arch/afio/afio-2.5.1-r1.ebuild b/app-arch/afio/afio-2.5.1-r1.ebuild
index 0c3a74af973a..a3e6e5c082ea 100644
--- a/app-arch/afio/afio-2.5.1-r1.ebuild
+++ b/app-arch/afio/afio-2.5.1-r1.ebuild
@@ -13,10 +13,9 @@ LICENSE="Artistic LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-PATCHES=( "${FILESDIR}"/Makefile-r1.patch )
+PATCHES=( "${FILESDIR}"/${PN}-2.5.1-fix-build-system.patch )
-src_prepare() {
- default
+src_configure() {
tc-export CC
}
@@ -27,7 +26,7 @@ src_install() {
local i
for i in {1..4}; do
- docinto "script$i"
- dodoc "script$i"/*
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
done
}
diff --git a/app-arch/afio/files/afio-2.5.1-fix-build-system.patch b/app-arch/afio/files/afio-2.5.1-fix-build-system.patch
new file mode 100644
index 000000000000..5f3e8355c1a2
--- /dev/null
+++ b/app-arch/afio/files/afio-2.5.1-fix-build-system.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -71,15 +71,12 @@
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+-
+-CC=gcc
+-
+-CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+-LDFLAGS =
++CC ?= gcc
++CFLAGS += -Wall -Wstrict-prototypes
++CPPFLAGS += ${LARGEFILEFLAGS} ${2} ${3} ${6} ${8} ${c} ${d} ${e2} ${f} ${g}
+
+ afio : afio.o compfile.o exten.o match.o $M
+- ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ clean:
+ rm -f *.o afio
diff --git a/app-arch/afio/metadata.xml b/app-arch/afio/metadata.xml
index b232df5209c8..1d91069b9e13 100644
--- a/app-arch/afio/metadata.xml
+++ b/app-arch/afio/metadata.xml
@@ -3,12 +3,12 @@
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>
-Afio makes cpio-format archives. It deals somewhat gracefully
-with input data corruption, supports multi-volume archives during interactive
-operation, and can make compressed archives that are much safer than compressed
-tar or cpio archives. Afio is best used as an 'archive engine' in a backup
-script.
-</longdescription>
+ Afio makes cpio-format archives. It deals somewhat gracefully
+ with input data corruption, supports multi-volume archives during interactive
+ operation, and can make compressed archives that are much safer than compressed
+ tar or cpio archives. Afio is best used as an 'archive engine' in a backup
+ script.
+ </longdescription>
<upstream>
<remote-id type="freshmeat">afio</remote-id>
</upstream>