summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-31 22:01:00 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-31 22:01:58 +0900
commitbd59e303a275c915bf174f22ad86f491a01f7fec (patch)
tree311e01f10cb15583c2bbf91904d3246b196d5002
parentapp-i18n/imsettings: drop gtk2 USE flag (diff)
downloadgentoo-bd59e303a275c915bf174f22ad86f491a01f7fec.tar.gz
gentoo-bd59e303a275c915bf174f22ad86f491a01f7fec.tar.bz2
gentoo-bd59e303a275c915bf174f22ad86f491a01f7fec.zip
app-i18n/imsettings: new upstream release
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/imsettings/Manifest1
-rw-r--r--app-i18n/imsettings/imsettings-1.8.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/imsettings/Manifest b/app-i18n/imsettings/Manifest
index 97bc272eeb72..03b0826442c5 100644
--- a/app-i18n/imsettings/Manifest
+++ b/app-i18n/imsettings/Manifest
@@ -1 +1,2 @@
DIST imsettings-1.7.2.tar.bz2 595754 BLAKE2B 9964ab7ca842a7e1b9e9c61434275b55d6a58e271dd12058195573aa65c623d5152a04bc893b3ac4d983c4798bd6f4e8cdb486577be45ec43db6600f72c8cc3b SHA512 b28d67705d3d6a0ec95babaca616f750b73cdac5e01ed61e25a6527fd7f816a14654cd7233eca56d7427b9395e7ad75757b95cd7bd55c56bbdc145a3f8bfe1f0
+DIST imsettings-1.8.2.tar.bz2 705391 BLAKE2B 3b7f3e2ca2c08bc149be95fb97889ab58fc22be828b9801f4c342c1514a7be35644548d6a920fe657e1d85a9d35d8c2a40766f25d6420bb3da8a8f4e7a7ba739 SHA512 600315a20fd61eaa77a0add1e587861ad3ce70175d87639e43105d804cec59bfbc0219f2177c4d9e07d337231eb85514cbfd8af614a113b688ead372075b9ff4
diff --git a/app-i18n/imsettings/imsettings-1.8.2.ebuild b/app-i18n/imsettings/imsettings-1.8.2.ebuild
new file mode 100644
index 000000000000..a3af54bc07ce
--- /dev/null
+++ b/app-i18n/imsettings/imsettings-1.8.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Delivery framework for general Input Method configuration"
+HOMEPAGE="https://tagoh.bitbucket.io/imsettings"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gconf qt5 +introspection xfconf"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libintl
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libgxim
+ x11-libs/libnotify
+ gconf? ( gnome-base/gconf )
+ introspection? ( dev-libs/gobject-introspection )
+ xfconf? ( xfce-base/xfconf )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/glib-utils
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-fno-common.patch )
+
+MY_XINPUTSH="90-xinput"
+
+src_prepare() {
+ sed -i \
+ -e "/PKG_CHECK_MODULES/s/\(gconf-2\.0\)/$(usex gconf '\1' _)/" \
+ -e "/PKG_CHECK_MODULES/s/\(gtk+-2\.0\)/_/" \
+ -e "/PKG_CHECK_MODULES/s/\(check\)/_/" \
+ -e "/PKG_CHECK_MODULES/s/\(libxfconf-0\)/$(usex xfconf '\1' _)/" \
+ -e "s/use_qt=\"yes\"/use_qt=\"$(usex qt5)\"/" \
+ -e "/^GNOME_/d" \
+ -e "/^CFLAGS/s/\$WARN_CFLAGS/-Wall -Wmissing-prototypes/" \
+ configure.ac
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-xinputsh=${MY_XINPUTSH}
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ fperms 0755 /etc/X11/xinit/xinitrc.d/${MY_XINPUTSH}
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EPREFIX}"/etc/X11/xinit/xinputrc ]]; then
+ ln -sf xinput.d/xcompose.conf "${EPREFIX}"/etc/X11/xinit/xinputrc
+ fi
+}