summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-05-22 21:21:48 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-05-22 21:21:48 +0000
commitbe128cd1dec752431a1629670f2bc7c46376a0ae (patch)
tree3e302f6b767abd6ab5a177de6fc7d145eca70528
parent2017-05-22 20:42:18 UTC (diff)
parentdev-python/unidecode: ppc ppc64 stable (bug 616976). (diff)
downloadgentoo-be128cd1dec752431a1629670f2bc7c46376a0ae.tar.gz
gentoo-be128cd1dec752431a1629670f2bc7c46376a0ae.tar.bz2
gentoo-be128cd1dec752431a1629670f2bc7c46376a0ae.zip
Merge updates from master
-rw-r--r--app-admin/lastpass-cli/Manifest1
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild44
-rw-r--r--dev-python/unidecode/unidecode-0.04.20.ebuild2
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-4.10.2.ebuild2
4 files changed, 47 insertions, 2 deletions
diff --git a/app-admin/lastpass-cli/Manifest b/app-admin/lastpass-cli/Manifest
index 14217969e062..17a37c73eb87 100644
--- a/app-admin/lastpass-cli/Manifest
+++ b/app-admin/lastpass-cli/Manifest
@@ -1 +1,2 @@
DIST lastpass-cli-1.0.0.tar.gz 92311 SHA256 42096c0bd3972b0e9cc9cef32fbf141e47b04b9e2387fb3abe8b105e135fb41e SHA512 4709b3e4d6064c8c5cb593344e6417355d7df570240dce8eb77a19f3377ea38585280a9602cf8ab926c55c6afd84b297f261b0c8a40d355734d5cc542d46f610 WHIRLPOOL 394bfb597f5262dd1e47c7a3c48ef093b398f90c6dcacac6b172bb008891c76faf448ecf6be0ebfa277d18d335b166b7efadc063acc57ce88274004d1734bf21
+DIST lastpass-cli-1.1.2.tar.gz 102796 SHA256 bc737d8e6d713c8aecdfb7f34b29aa9a8ae9b1e9ba80b31059686b18591a8c39 SHA512 8115cb07cfca15ef402bdbd8ce943352e1534ddb781274e21cb0fafa4bcd9ab7abe4ddba57c4ebbce326f09cc9249f244607d16cac5597e61cf21c73417e7d9c WHIRLPOOL c7e6a4d5ac9b8c52f53e081b367289b390704fa4dfbf13a9ea0086e4ca0d49f9ef5a39f9ea854387ffb66fbd18f9b5263d17ae6573c4286fb7a36ebdce724d7f
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
new file mode 100644
index 000000000000..d81e760b556d
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBASH_COMPLETION_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile all doc-man
+}
+
+src_install() {
+ cmake-utils_src_install install install-doc
+}
diff --git a/dev-python/unidecode/unidecode-0.04.20.ebuild b/dev-python/unidecode/unidecode-0.04.20.ebuild
index dcdb0681a1ee..be16fa8e8bfc 100644
--- a/dev-python/unidecode/unidecode-0.04.20.ebuild
+++ b/dev-python/unidecode/unidecode-0.04.20.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 arm hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm hppa ppc ppc64 ~sparc ~x86"
S=${WORKDIR}/${MY_P}
diff --git a/sys-fs/btrfs-progs/btrfs-progs-4.10.2.ebuild b/sys-fs/btrfs-progs/btrfs-progs-4.10.2.ebuild
index 0f4ee9f4fd65..78bee65b60c4 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-4.10.2.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-4.10.2.ebuild
@@ -9,7 +9,7 @@ libbtrfs_soname=0
if [[ ${PV} != 9999 ]]; then
MY_PV=v${PV}
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~mips ppc ~ppc64 ~sparc x86"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~mips ppc ppc64 ~sparc x86"
SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
S="${WORKDIR}"/${PN}-${MY_PV}
else