summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-07 05:44:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-07 05:45:15 -0400
commitbe7b8b731fca352feb69499b08fa3918bcb71309 (patch)
tree662b926609564c548a481361e5af8426ffa2d979
parentapp-emulation/wine-staging: fix build with musl (diff)
downloadgentoo-be7b8b731fca352feb69499b08fa3918bcb71309.tar.gz
gentoo-be7b8b731fca352feb69499b08fa3918bcb71309.tar.bz2
gentoo-be7b8b731fca352feb69499b08fa3918bcb71309.zip
app-emulation/wine-vanilla: fix build with musl
Closes: https://bugs.gentoo.org/931341 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/wine-vanilla/files/wine-vanilla-9.8-musl-ioctls-header.patch30
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/files/wine-vanilla-9.8-musl-ioctls-header.patch b/app-emulation/wine-vanilla/files/wine-vanilla-9.8-musl-ioctls-header.patch
new file mode 100644
index 000000000000..7aa1a4c00587
--- /dev/null
+++ b/app-emulation/wine-vanilla/files/wine-vanilla-9.8-musl-ioctls-header.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/931341
+https://gitlab.winehq.org/wine/wine/-/commit/24ca848c568d5a2786abd26f2e7314b2e3f509f3
+From: Fotios Valasiadis <fvalasiad@gmail.com>
+Date: Sun, 5 May 2024 03:34:57 +0300
+Subject: [PATCH] ntdll/unix: Fix building on musl by explicitly including
+ asm/ioctls.h.
+
+After commit 898ab8dab19d498c17859f39a55e317ee7e367a5 wine would no longer
+build on musl.
+
+Issue is that apparently TCSETS2 isn't defined when including sys/ioctl.h.
+
+A little digging shows that glibc goes ahead and includes asm/ioctls.h in
+sys/ioctl.h, providing said macro. Musl on the other hand doesn't and relies
+on bits/ioctl.h, which lacks said macro.
+
+Signed-off-by: Fotios Valasiadis <fvalasiad@gmail.com>
+--- a/dlls/ntdll/unix/serial.c
++++ b/dlls/ntdll/unix/serial.c
+@@ -33,6 +33,7 @@
+ #include <stdio.h>
+ #ifdef HAVE_ASM_TERMBITS_H
+ # include <asm/termbits.h>
++# include <asm/ioctls.h>
+ #else
+ # include <termios.h>
+ #endif
+--
+GitLab
+
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
index 13bbfdc159ea..7a5546bbfd70 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
@@ -161,6 +161,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.0-noexecstack.patch
"${FILESDIR}"/${PN}-7.20-unwind.patch
"${FILESDIR}"/${PN}-8.13-rpath.patch
+ "${FILESDIR}"/${P}-musl-ioctls-header.patch
)
pkg_pretend() {