summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 04:55:29 +0000
committerSam James <sam@gentoo.org>2023-11-25 04:55:29 +0000
commitbfe965837ccf956b3242dc77f30e49f5caef60c0 (patch)
tree3dbcee75e1918f416fa2e0f474133a6b4dba385d
parentsys-apps/usbutils: add 017 (diff)
downloadgentoo-bfe965837ccf956b3242dc77f30e49f5caef60c0.tar.gz
gentoo-bfe965837ccf956b3242dc77f30e49f5caef60c0.tar.bz2
gentoo-bfe965837ccf956b3242dc77f30e49f5caef60c0.zip
sys-apps/fakeroot: add 1.32.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.32.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index 03e7b93d10dc..78009b263885 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1,2 +1,3 @@
DIST fakeroot_1.31.orig.tar.gz 551366 BLAKE2B f9b766f233f1f731399a814d1936b1dbdd64808a411ba11c4f460fe2eb66d3a5d40fd907d3d6cf6d9f0d062ad24319bee379da0609bbb9b0e1b7f17a889643b0 SHA512 a66a3535c2088ba8c33e3afc18d2ab1a16a502b999a4efbea7542e345181aa172af2e0949989832cda69bf6753c80a4bfc12cc283f5da11de31aa0bee0e8b47b
DIST fakeroot_1.32.1.orig.tar.gz 551727 BLAKE2B 62befaabcddcc9ba75d5df6e81412a83dd82e76febbc03fe7e37e2f607d48ed2126db794b4a6ac7f0a9ddb04cf431050d959fb81665bd60837a1713f2d937970 SHA512 fe8263ca9b90e4df253311e5331721a8783260a1058b307d10ffbde47724fc24df584806b17af4477be47d90dc553abe6a476e02cf8ce2aebdd94357ff7d7f09
+DIST fakeroot_1.32.2.orig.tar.gz 571345 BLAKE2B 796ad9a43fb6390ff9a286940517c84c0c4c304cdb9316bcb65da4e7a763e3911a3524cb47b797a48bec55e9f0ce587bd571ed11097ef4c4d4b6979609e4b4e4 SHA512 62fd597f8fb7e2d977892851a5dc579d431fc9a25fd0ce02e3997ac6be3d22edd9cf03ede68cf961096de86659962f9f04e0e747074ea3c79931c0413c32612a
diff --git a/sys-apps/fakeroot/fakeroot-1.32.2.ebuild b/sys-apps/fakeroot/fakeroot-1.32.2.ebuild
new file mode 100644
index 000000000000..00707249475b
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.32.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="de es fr nl pt ro sv"
+inherit autotools flag-o-matic plocale
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug nls test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )
+"
+BDEPEND="nls? ( app-text/po4a )"
+
+DOCS=( AUTHORS BUGS DEBUG README doc/README.saving )
+
+src_prepare() {
+ default
+
+ disable_locale() {
+ local locale=${1}
+
+ sed -i -e "s: ${locale}::" doc/po4a/po4a.cfg doc/Makefile.am || die
+ }
+
+ plocale_find_changes doc/po4a/po '' '.po'
+ plocale_for_each_disabled_locale disable_locale
+
+ # We could make this conditional and disable the autodependency in
+ # autotools.eclass but it'd make it too easy for NLS builds to be broken
+ # and us not realise.
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+ use acl || export ac_cv_search_acl_get_fd=no # bug 759568
+ use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
+
+ # https://bugs.gentoo.org/834445
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
+ econf --disable-static
+}
+
+src_compile() {
+ local enabled_locales=$(plocale_get_locales)
+
+ if use nls && [[ -n ${enabled_locales} ]] ; then
+ # Create translated man pages
+ pushd doc >/dev/null || die
+ po4a -v -k 0 --variable "srcdir=${S}/doc/" po4a/po4a.cfg || die
+ popd >/dev/null || die
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}