summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 15:54:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 15:56:11 +0200
commitc086f8d6b02050d72cd8b78005dc0442084221f8 (patch)
tree2dc30b22f262074be8e53bb96e56783c7f5b5461
parentdev-python/autopage: Bump to 0.5.2 (diff)
downloadgentoo-c086f8d6b02050d72cd8b78005dc0442084221f8.tar.gz
gentoo-c086f8d6b02050d72cd8b78005dc0442084221f8.tar.bz2
gentoo-c086f8d6b02050d72cd8b78005dc0442084221f8.zip
dev-python/aiodns: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-3.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index 6a8648ad761a..38141778de8c 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1,2 +1,3 @@
DIST aiodns-3.0.0.tar.gz 6743 BLAKE2B 2a3c61156069fa598df58191b35383da3e054396cdeb1bc8916cc0414bb6efc89d45789883a5b4f33e3a08a6ee544356b02d6c697c096deae3398f0ff4d3c316 SHA512 8c1016f3b0cb461e70e9a55034f9ad3b3db705a845bf20bb6503c7a5d592b4c5d2e8ddc60b375c5fafdc559dc4566736f4c93f26710be2dcbd181284ef039825
DIST aiodns-3.1.0.tar.gz 7156 BLAKE2B 0d3b5b84631e3ed378c4334966391a639d577fb6b983b4c8cbaf306fcbb167e897b6094f9cbb3a7fb8355c352830feda1fee3a923044bf5219836845d162d1b3 SHA512 6e432555924a3d53ba95ed160a6211486041dfee8c16f18cfd23be3f1d6a50a1fad28fd406acc5de87ba277f7172c3d8ff84633585323a3f659312c4a713b096
+DIST aiodns-3.1.1.tar.gz 7363 BLAKE2B bb5a465be00ff61406b61cef133cb5eed8e007114ddcd1475a12fed5481ec377bc96291fdc7fd6cc5936de865118f7008625ec5d69c09f96eacdb83b4b29c786 SHA512 7c28cc6256a575681778376cc197a9504133b1127eb3508f6e5cd1c992c95adef66cf8399b7e90ca012347485e476f71e3f032f7e2f555954ad9a0cade8df5f9
diff --git a/dev-python/aiodns/aiodns-3.1.1.ebuild b/dev-python/aiodns/aiodns-3.1.1.ebuild
new file mode 100644
index 000000000000..1745292c2be6
--- /dev/null
+++ b/dev-python/aiodns/aiodns-3.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet changed, https://github.com/saghul/aiodns/issues/107
+ tests.py::DNSTest::test_query_bad_chars
+ )
+
+ epytest tests.py
+}