summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-30 18:22:46 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-30 18:59:21 -0600
commitc0e216403830d361b699643b6d6f0555c840d23c (patch)
treee2604f534b41f368c1aa2b463d0c6aa93dbbd9e4
parentgames-action/transcend: remove deprecated games eclass (diff)
downloadgentoo-c0e216403830d361b699643b6d6f0555c840d23c.tar.gz
gentoo-c0e216403830d361b699643b6d6f0555c840d23c.tar.bz2
gentoo-c0e216403830d361b699643b6d6f0555c840d23c.zip
games-action/wordwarvi: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
-rw-r--r--games-action/wordwarvi/wordwarvi-1.00-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-action/wordwarvi/wordwarvi-1.00-r1.ebuild b/games-action/wordwarvi/wordwarvi-1.00-r1.ebuild
new file mode 100644
index 000000000000..1d6096e377af
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-1.00-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CC-BY-2.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="x11-libs/gtk+:2
+ portaudio? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sound.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^WITHAUDIO/s/yes/$(use portaudio && echo yes || echo no)/" \
+ Makefile || die
+ sed -i \
+ -e "s:GENTOO_DATADIR:/usr/share/${PN}:" \
+ wwviaudio.c || die
+}
+
+src_compile() {
+ emake \
+ PREFIX="/usr" \
+ DATADIR="/usr/share/${PN}" \
+ MANDIR="/usr/share/man"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="/usr" \
+ DATADIR="/usr/share/${PN}" \
+ MANDIR="/usr/share/man" \
+ install
+
+ if ! use portaudio ; then
+ rm -rf "${D}/usr/share" || die
+ fi
+
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+}