summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-02 12:13:02 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-02 22:09:05 +0200
commitc50de871c8604bf7944be6e53b4932f4629896a7 (patch)
tree48a5b054efc65f8c32863d7bc471fc0d8966d4a5
parentsci-astronomy/xfitsview: Deleted EAPI 4 ebuild xfitsview-2.2-r1.ebuild (diff)
downloadgentoo-c50de871c8604bf7944be6e53b4932f4629896a7.tar.gz
gentoo-c50de871c8604bf7944be6e53b4932f4629896a7.tar.bz2
gentoo-c50de871c8604bf7944be6e53b4932f4629896a7.zip
sci-libs/buddy: revbump (EAPI 4 -> 6)
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2188 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/buddy/buddy-2.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/buddy/buddy-2.4-r1.ebuild b/sci-libs/buddy/buddy-2.4-r1.ebuild
new file mode 100644
index 000000000000..1bf0d298789c
--- /dev/null
+++ b/sci-libs/buddy/buddy-2.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit fortran-2
+
+DESCRIPTION="Binary Decision Diagram Package"
+HOMEPAGE="https://sourceforge.net/projects/buddy/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="buddy"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DOCS=( doc/tech.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use doc && docinto ps && dodoc doc/*.ps
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
+}