summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-22 03:01:26 +0100
committerSam James <sam@gentoo.org>2022-05-22 03:30:09 +0100
commitc54eda13aa09a85c4b22f27cbd098c928b8b702d (patch)
tree40d5ccb2bb21a12897bb7ff3ee84fc7a72d045f7
parentmail-filter/rspamd: add selinux USE flag (diff)
downloadgentoo-c54eda13aa09a85c4b22f27cbd098c928b8b702d.tar.gz
gentoo-c54eda13aa09a85c4b22f27cbd098c928b8b702d.tar.bz2
gentoo-c54eda13aa09a85c4b22f27cbd098c928b8b702d.zip
sys-apps/hwdata: add 0.359
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.359.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index ec9cb9aec9d2..3a3f2c448ba4 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1,3 +1,4 @@
DIST hwdata-0.354.tar.gz 2212834 BLAKE2B 5df04fd6069e131be7195b515f4f7273e28030d46823fa3054371f9afde4eb9976df2663bc7d31d056cb718a479630676f05459064decd59914f3a69bcfb03f1 SHA512 07bbe5137f35c0402029e066e90a29da1ca95faa6996a192b1f9ac00568e5020cc540b642ad2b22b25c2cfa0d7e4c2d7b80c9978ca0cd091691d8f1cf2933915
DIST hwdata-0.357.tar.gz 2234392 BLAKE2B 54f26384664cc78d99db52cffa99bf74f57bf355908bd0a87bd01436596b8ed618567caa6f4486e32cbf11bd9313946db2f4d52ce7f2eae1d25b643e68714473 SHA512 7674e77887629e57cf1d6cb73ce7f4734f9dd5e5f8cee0016aa74f0ff6b962f9f0e501069f4cbaa0a5281fed179d2912a653071999b9f7d0eb4d81fff719cad1
DIST hwdata-0.358.tar.gz 2240851 BLAKE2B b164c267a6779fec2a4018fb8bad98e564794e46cdec77b6f1234444f0fb20f49f44303a400d3301b40b07cebe0cc590553ae5e01702032b53180826273eb416 SHA512 52c765786aa41551e47bad2358bbe50f8f6a60cd820696c6c341f08cbde695f86746660a3fdadd8fad5614b99a98616111011a17d115c25bbcaf03c891cc3e69
+DIST hwdata-0.359.tar.gz 2247837 BLAKE2B af573e38cc04281e18e202fe134430cca3f85129196ff793571f1aa12c2380719e470941e4c8ab74cc888b5f06498d70af2ac1604e758b77f329e11043aae4c0 SHA512 e3054ded9ff913498f27206829af91cfd816acc0cb574f85207f6df5568502c28ff9d4a778549c900e90dcc8958deb45a1eb1511bae57b3240472402576b4943
diff --git a/sys-apps/hwdata/hwdata-0.359.ebuild b/sys-apps/hwdata/hwdata-0.359.ebuild
new file mode 100644
index 000000000000..81b4b0771008
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.359.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+ echo "${conf[@]}" >&2
+ "${conf[@]}" || die
+}