summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-04 19:53:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-04 19:53:04 +0300
commitc56e519fba697a28c97e3dfc000ff3764dd8fa18 (patch)
tree9c9d6d5a70520a9dc52b1b79bc9c534e226f90ff
parentgui-libs/gtk: Stabilize 4.10.3 sparc, #905490 (diff)
downloadgentoo-c56e519fba697a28c97e3dfc000ff3764dd8fa18.tar.gz
gentoo-c56e519fba697a28c97e3dfc000ff3764dd8fa18.tar.bz2
gentoo-c56e519fba697a28c97e3dfc000ff3764dd8fa18.zip
app-admin/github-backup-utils: add 3.8.0
Closes: https://bugs.gentoo.org/896466 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/github-backup-utils/Manifest1
-rw-r--r--app-admin/github-backup-utils/github-backup-utils-3.8.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/github-backup-utils/Manifest b/app-admin/github-backup-utils/Manifest
index c11b5468fc2f..faf378eb7a06 100644
--- a/app-admin/github-backup-utils/Manifest
+++ b/app-admin/github-backup-utils/Manifest
@@ -1,3 +1,4 @@
DIST github-backup-utils-3.0.0.tar.gz 104088 BLAKE2B f01229e6b152231eb832dec8bef41bb158cc200bbdd3c59c1abab299c572902efe6d27d093491bd8b0bf8f3e834d2938eb0127d5f28700ba75dcbdbcc8a21bb8 SHA512 e86420ef9d86d44560e27e00361ff1bb8ba7c15fb116ad9981e3196bc4c7c25bcff9a9f7dc8dae9bbbb9b2f3380b434199dbbe1ef7db5b1ba04ec1233aec320d
DIST github-backup-utils-3.3.2.tar.gz 109517 BLAKE2B b9c48de60f10d1d20eda96d0fa69c7d1835c0cdca7dbb3a3659e2a527706d6d793c426d5032e2bd1ead58255cdca6cdf424da0cb6a06484c4a5b5a9b0d4bcbba SHA512 c8013d5775a0ad8193266c36b0afa91bd452dfd70499c74239c6e62a0c9d88ecd92e16495ad4bd64319e42ad7b781125c136b1a9945146d09add5a2165d31b16
DIST github-backup-utils-3.5.0.tar.gz 113871 BLAKE2B e6835c3efe04332df792827e2fdc54449e73a1fec055e7677174a1eaf2b4c9d43a2bc4c82741b056265fbf4eeea75ad62819d9d357d800ff3d4befcf5fcd4e39 SHA512 d77e30fe426b231c8d8aa1ca7867861a3427a5829d46184283a1beaea22b697dd6cf7343d1e65f40c9f6f9bcd05fea0c45892080292707b6b897599d4cbb566b
+DIST github-backup-utils-3.8.0.tar.gz 116694 BLAKE2B 481f0c4345d1de791d023c906d58424d96bf9e96fd3e5d50f081f6cbdd29b4e068f4414db6e808511adb8110e609416490ba36140b5dfabcf2e738b7b91e6121 SHA512 327d777f0134838ab6d1b3e3dc702b35e81f8a682339638b248dfdd9580fdea5435cad5a4a539c65d91832a8b02f86e3bdd546c312fcfe9c1ef13d858bbadb9f
diff --git a/app-admin/github-backup-utils/github-backup-utils-3.8.0.ebuild b/app-admin/github-backup-utils/github-backup-utils-3.8.0.ebuild
new file mode 100644
index 000000000000..ff176f840c72
--- /dev/null
+++ b/app-admin/github-backup-utils/github-backup-utils-3.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit python-any-r1
+
+DESCRIPTION="Backup and recovery utilities for GitHub Enterprise"
+HOMEPAGE="https://github.com/github/backup-utils"
+SRC_URI="https://github.com/github/backup-utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN/#github-/}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moreutils parallel is now used for speedups in main code:
+# https://github.com/github/backup-utils/pull/635
+RDEPEND="app-misc/jq
+ app-arch/pigz
+ net-misc/rsync
+ sys-apps/moreutils"
+
+# tests invoke parallel & rsync
+DEPEND="test? (
+ ${RDEPEND}
+ dev-util/checkbashisms
+ ${PYTHON_DEPS}
+)"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ dobin bin/*
+ insinto usr/share/${PN}
+ doins share/${PN}/version
+
+ exeinto usr/share/${PN}
+ doexe share/${PN}/bm.sh
+ doexe share/${PN}/ghe-*
+
+ insinto etc/${PN}
+ newins backup.config-example backup.config
+
+ dodoc -r docs/*
+}
+
+src_test() {
+ emake test
+}