summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-25 07:14:47 +0000
committerSam James <sam@gentoo.org>2023-01-25 07:14:47 +0000
commitc5a5d8a318235f13e1c46719d77bc45ea574421a (patch)
tree256f289e4419a2951a95dcca3d7d52b44841779b
parentnet-misc/streamlink: add 5.2.1 (diff)
downloadgentoo-c5a5d8a318235f13e1c46719d77bc45ea574421a.tar.gz
gentoo-c5a5d8a318235f13e1c46719d77bc45ea574421a.tar.bz2
gentoo-c5a5d8a318235f13e1c46719d77bc45ea574421a.zip
app-emulation/virt-what: add 1.25
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/virt-what/Manifest1
-rw-r--r--app-emulation/virt-what/virt-what-1.25.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/virt-what/Manifest b/app-emulation/virt-what/Manifest
index de8d111b70bc..266b97d053ce 100644
--- a/app-emulation/virt-what/Manifest
+++ b/app-emulation/virt-what/Manifest
@@ -1 +1,2 @@
DIST virt-what-1.21.tar.gz 478767 BLAKE2B 7c48b84d9f1fe5f734921f68848b84beee2e5687a6ebfbc422a1349063e6a83c932a89cb2936239da6be033b72e6010694314cf106486cd6c54cd02652bc61a6 SHA512 14ace184c4aee5a09b855c1f5acaa619057aed1b9bf03c91ed1003e6a39ea69162c9fe452ea8162c7fe29825e0e2202cfc7d76e82f0cecea3e32405e5eb9f717
+DIST virt-what-1.25.tar.gz 516445 BLAKE2B 3f3403a3954e359005754e1ad2aba545a824ff9eb77e787615235c1042735f99a58d89f755c265324c16a9d0467e8332a67dff88b3ac15ae21a4f4f7a6dd3136 SHA512 0147b4b44ae0ee685977aa34dfa9bf30ae8e0eb31b7a6d5c0097d16f830fa6fb6afd7156964fc79f3fd5e82b2f68d921fd5306245cc63a2140f6dddc7fdd0e98
diff --git a/app-emulation/virt-what/virt-what-1.25.ebuild b/app-emulation/virt-what/virt-what-1.25.ebuild
new file mode 100644
index 000000000000..d078ced80f50
--- /dev/null
+++ b/app-emulation/virt-what/virt-what-1.25.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Detects if the current machine is running in a virtual machine"
+HOMEPAGE="https://people.redhat.com/~rjones/virt-what/"
+SRC_URI="https://people.redhat.com/~rjones/virt-what/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="dmi"
+
+DEPEND="dev-lang/perl"
+RDEPEND="app-shells/bash
+ dmi? ( sys-apps/dmidecode )"
+
+src_prepare() {
+ default
+
+ # Pretends to be POSIX sh while it is not
+ sed -e 's:/bin/sh:/bin/bash:' -i virt-what.in || die
+}