summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-15 18:41:05 -0600
committerJoonas Niilola <juippis@gentoo.org>2023-12-01 09:52:17 +0200
commitc61c407ec58a2553d935319a367ee68ade1ecad3 (patch)
treeafdb66d3b85a84d73537bdbc797f996226b76ab5
parentapp-dicts/mecab-unidic: update EAPI 6 -> 8 (diff)
downloadgentoo-c61c407ec58a2553d935319a367ee68ade1ecad3.tar.gz
gentoo-c61c407ec58a2553d935319a367ee68ade1ecad3.tar.bz2
gentoo-c61c407ec58a2553d935319a367ee68ade1ecad3.zip
app-dicts/wnn-ldic: update EAPI 6 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-dicts/wnn-ldic/wnn-ldic-1.04-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-dicts/wnn-ldic/wnn-ldic-1.04-r1.ebuild b/app-dicts/wnn-ldic/wnn-ldic-1.04-r1.ebuild
new file mode 100644
index 000000000000..350c879e0a8d
--- /dev/null
+++ b/app-dicts/wnn-ldic/wnn-ldic-1.04-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Wnn dictionary for librarian"
+#HOMEPAGE="http://www.tulips.tsukuba.ac.jp/misc/export/cat/ldic"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/ldic-${PV}-wnn.txt"
+S="${WORKDIR}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="app-i18n/freewnn"
+
+src_unpack() {
+ :
+}
+
+src_compile() {
+ local atod=atod
+ if has_version "<app-i18n/freewnn-1.1.1_alpha23"; then
+ atod="${BROOT}"/usr/bin/Wnn4/atod
+ fi
+ "${atod}" lib.dic < "${DISTDIR}"/${A} || die
+}
+
+src_install() {
+ insinto /usr/lib/wnn/ja_JP/dic/misc
+ doins lib.dic
+}
+
+pkg_postinst() {
+ elog "lib.dic is installed in ${EPREFIX}/usr/lib/wnn/ja_JP/dic/misc."
+ elog "You have to edit your wnnenvrc or eggrc to use it."
+}