summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-02-13 10:08:15 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-13 10:11:46 +0100
commitc650e447516bc49b5d63e7336c86e01cf2454c4e (patch)
tree3934a397d1a8ee44e7da2494f86fe28f97635ac6
parentdev-java/touchgraph-graphlayout: treeclean (diff)
downloadgentoo-c650e447516bc49b5d63e7336c86e01cf2454c4e.tar.gz
gentoo-c650e447516bc49b5d63e7336c86e01cf2454c4e.tar.bz2
gentoo-c650e447516bc49b5d63e7336c86e01cf2454c4e.zip
dev-java/tomcat-jstl-impl: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-java/tomcat-jstl-impl/Manifest1
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch35
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch33
-rw-r--r--dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml244
-rw-r--r--dev-java/tomcat-jstl-impl/metadata.xml8
-rw-r--r--dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5-r1.ebuild81
-rw-r--r--profiles/package.mask1
7 files changed, 0 insertions, 403 deletions
diff --git a/dev-java/tomcat-jstl-impl/Manifest b/dev-java/tomcat-jstl-impl/Manifest
deleted file mode 100644
index 2a12b9cd6b78..000000000000
--- a/dev-java/tomcat-jstl-impl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST tomcat-jstl-impl-1.2.5.zip 615779 BLAKE2B f5c307625a84a7170659683913282df1cf7e8b6a021ffed9895aa0e770a35d8db5351660c96668091ed59e5be35d2e8ad9359f524cbfe5a380e89ebe4fe08b43 SHA512 ad4122cd75c66df901034e333c2b38ac3d2d8f5b0299abd36d0fd1c8f5975eacc71d66a475fc05638dd562ab0670ea532fe6a3ccb5497dfbeb9d859b03b659d0
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch
deleted file mode 100644
index f43dfc1f903b..000000000000
--- a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-ImportSupport.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- impl/src/main/java/org/apache/taglibs/standard/tag/common/core/ImportSupport.java.orig 2015-06-01 22:34:34.882000000 +0000
-+++ impl/src/main/java/org/apache/taglibs/standard/tag/common/core/ImportSupport.java 2015-06-01 22:35:29.078000000 +0000
-@@ -36,6 +36,7 @@
- import javax.servlet.ServletContext;
- import javax.servlet.ServletException;
- import javax.servlet.ServletOutputStream;
-+import javax.servlet.WriteListener;
- import javax.servlet.http.HttpServletRequest;
- import javax.servlet.http.HttpServletResponse;
- import javax.servlet.http.HttpServletResponseWrapper;
-@@ -430,6 +431,24 @@
- public void write(int b) throws IOException {
- bos.write(b);
- }
-+
-+ @Override
-+ public boolean isReady() {
-+ return true;
-+ }
-+
-+ @Override
-+ public void setWriteListener(WriteListener writeListener) {
-+ }
-+
-+ @Override
-+ public void close() throws IOException {
-+ }
-+
-+ @Override
-+ public void flush() throws IOException {
-+ }
-+
- };
-
- /**
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch
deleted file mode 100644
index 9ed4ed84a38d..000000000000
--- a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-SetSupport.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- impl/src/test/java/org/apache/taglibs/standard/tag/common/core/SetSupportTest.java.orig 2015-06-01 22:59:35.208000000 +0000
-+++ impl/src/test/java/org/apache/taglibs/standard/tag/common/core/SetSupportTest.java 2015-06-01 22:59:54.191000000 +0000
-@@ -334,30 +334,12 @@
- }
-
- @Test
-- public void testResultFromBodyContent() throws JspException {
-- tag = new MockSetSupport();
-- BodyContent bodyContent = createMock(BodyContent.class);
-- expect(bodyContent.getString()).andStubReturn(" Hello ");
-- replay(bodyContent);
-- tag.setBodyContent(bodyContent);
-- Assert.assertEquals(VALUE, tag.getResult());
-- }
--
-- @Test
- public void testResultFromNullBodyContent() throws JspException {
- tag = new MockSetSupport();
- tag.setBodyContent(null);
- Assert.assertEquals(tag.getResult(), "");
- }
-
-- @Test
-- public void testResultFromEmptyBodyContent() throws JspException {
-- tag = new MockSetSupport();
-- BodyContent bodyContent = createMock(BodyContent.class);
-- expect(bodyContent.getString()).andStubReturn(null);
-- Assert.assertEquals("", tag.getResult());
-- }
--
- public static class MockSetSupport extends SetSupport {
- private final boolean valueSpecified;
- private final Object value;
diff --git a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml b/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml
deleted file mode 100644
index fce6b8d72338..000000000000
--- a/dev-java/tomcat-jstl-impl/files/tomcat-jstl-impl-1.2.5-build.xml
+++ /dev/null
@@ -1,244 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 6/1/15 9:48 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="taglibs-standard-impl-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="taglibs-standard-impl-1.2.5"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- </path>
- <path id="build.test.classpath">
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- <exclude name="**/ExprSupportTest.java"/>
- <exclude name="**/EscapeXMLTest.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- <exclude name="**/ExprSupportTest.java"/>
- <exclude name="**/EscapeXMLTest.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false">
- <link href="http://download.oracle.com/javase/1.5.0/docs/api"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class" value="Main"/>
- </manifest>
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-</project>
diff --git a/dev-java/tomcat-jstl-impl/metadata.xml b/dev-java/tomcat-jstl-impl/metadata.xml
deleted file mode 100644
index 4221e170cbc0..000000000000
--- a/dev-java/tomcat-jstl-impl/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5-r1.ebuild b/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5-r1.ebuild
deleted file mode 100644
index 80abba919d84..000000000000
--- a/dev-java/tomcat-jstl-impl/tomcat-jstl-impl-1.2.5-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-MY_PN="taglibs-standard"
-MY_P="${MY_PN}-${PV}"
-MY_IMPL="${MY_PN}-impl"
-
-DESCRIPTION="JSP Standard Tag Library (JSTL) - Implementation jar"
-HOMEPAGE="https://tomcat.apache.org/taglibs/standard/"
-SRC_URI="http://apache.mirrors.ovh.net/ftp.apache.org/dist/tomcat/taglibs/${MY_P}/${MY_P}-source-release.zip -> ${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-java/xalan:0
- dev-java/tomcat-jstl-spec:0
- dev-java/tomcat-servlet-api:3.1"
-
-RDEPEND="
- ${CDEPEND}
- >=virtual/jre-1.6"
-
-DEPEND="
- ${CDEPEND}
- test? (
- dev-java/ant-junit:0
- dev-java/easymock:3.2
- )
- >=virtual/jdk-1.6"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-EANT_GENTOO_CLASSPATH="tomcat-servlet-api-3.1,tomcat-jstl-spec,xalan"
-EANT_BUILD_TARGET="package"
-EANT_BUILD_XML="impl/build.xml"
-
-JAVA_RM_FILES=(
- impl/src/test/java/org/apache/taglibs/standard/tag/common/fmt/BundleSupportTest.java
-)
-
-PATCHES=(
- # This patch overrides a couple of methods.
- "${FILESDIR}"/${P}-ImportSupport.patch
- # This one disables one test case which doesn't work.
- "${FILESDIR}"/${P}-SetSupport.patch
-)
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml "${S}"/impl/build.xml || die
-
- epatch "${PATCHES[@]}"
-}
-
-EANT_TEST_TARGET="test"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},easymock-3.2"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar "${S}"/impl/target/${MY_IMPL}-${PV}.jar ${MY_IMPL}.jar
-
- if use doc; then
- java-pkg_dohtml -r "${S}"/impl/target/site/apidocs/
- fi
-
- if use source; then
- java-pkg_dosrc "${S}"/impl/src/*
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 12a12c950d29..8617096006eb 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -238,7 +238,6 @@ dev-java/kunststoff
dev-java/saxpath
dev-java/sun-jaf
dev-java/tijmp
-dev-java/tomcat-jstl-impl
# Ulrich Müller <ulm@gentoo.org> (2022-01-15)
# Pretest versions, masked for testing.