summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCasper Hanegreefs <casinvictusgentoo@proton.me>2023-02-20 17:26:20 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-02-22 20:37:48 +0200
commitc6b692cbc96a8f34baa10ec50016b95854b6fdb4 (patch)
tree78bb0f4090fee2ac6ec5893bc81697b8f797c6a2
parentsys-devel/llvm sys-devel/clang: GCC -flto ICE mitigation (diff)
downloadgentoo-c6b692cbc96a8f34baa10ec50016b95854b6fdb4.tar.gz
gentoo-c6b692cbc96a8f34baa10ec50016b95854b6fdb4.tar.bz2
gentoo-c6b692cbc96a8f34baa10ec50016b95854b6fdb4.zip
app-crypt/moolticute: v0.43.19 fixes udev, systemd USE flag, EAPI 8
Signed-off-by: Casper Hanegreefs <casinvictusgentoo@proton.me> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--app-crypt/moolticute/files/50-mooltipass.rule1
-rw-r--r--app-crypt/moolticute/files/50-mooltipass.rules15
-rw-r--r--app-crypt/moolticute/files/moolticuted.init6
-rw-r--r--app-crypt/moolticute/files/moolticuted.init-r112
-rw-r--r--app-crypt/moolticute/moolticute-0.43.19-r1.ebuild66
-rw-r--r--app-crypt/moolticute/moolticute-0.43.19-r2.ebuild (renamed from app-crypt/moolticute/moolticute-0.43.19.ebuild)20
6 files changed, 29 insertions, 91 deletions
diff --git a/app-crypt/moolticute/files/50-mooltipass.rule b/app-crypt/moolticute/files/50-mooltipass.rule
deleted file mode 100644
index 4bfd907d7257..000000000000
--- a/app-crypt/moolticute/files/50-mooltipass.rule
+++ /dev/null
@@ -1 +0,0 @@
-SUBSYSTEM=="usb", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="09a0", TAG+="uaccess"
diff --git a/app-crypt/moolticute/files/50-mooltipass.rules b/app-crypt/moolticute/files/50-mooltipass.rules
new file mode 100644
index 000000000000..8492743bab93
--- /dev/null
+++ b/app-crypt/moolticute/files/50-mooltipass.rules
@@ -0,0 +1,15 @@
+# udev rules for allowing console user(s) and libusb access to Mooltipass Mini devices
+# Used udev rules from https://github.com/mooltipass/mooltipass-udev
+ACTION!="add|change", GOTO="mooltipass_end"
+
+# console user
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="09a0", MODE="0660", SYMLINK+="mooltipass_keyboard", TAG+="uaccess", TAG+="udev-acl"
+SUBSYSTEM=="hidraw", ATTRS{idVendor}=="1209", ATTRS{idProduct}=="4321", MODE="0660", SYMLINK+="mooltipass_keyboard", TAG+="uaccess", TAG+="udev-acl"
+# libusb
+SUBSYSTEM=="usb", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="09a0", MODE="0660", SYMLINK+="mooltipass_device", TAG+="uaccess"
+SUBSYSTEM=="usb", ATTRS{idVendor}=="1209", ATTRS{idProduct}=="4321", MODE="0660", SYMLINK+="mooltipass_device", TAG+="uaccess"
+
+# required for newer versions of bluez
+SUBSYSTEM=="hidraw", KERNELS=="*1209:4321*", MODE="0660", SYMLINK+="mooltipass_keyboard", TAG+="uaccess", TAG+="udev-acl"
+
+LABEL="mooltipass_end"
diff --git a/app-crypt/moolticute/files/moolticuted.init b/app-crypt/moolticute/files/moolticuted.init
index 4a331db1c3a4..56b15ff3d5c2 100644
--- a/app-crypt/moolticute/files/moolticuted.init
+++ b/app-crypt/moolticute/files/moolticuted.init
@@ -1,11 +1,11 @@
#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
command=/usr/bin/moolticuted
-command_args=""
+command_background="yes"
pidfile=/var/run/moolticuted.pid
-start_stop_daemon_args="--make-pidfile --background --user nobody --group usb"
+command_user="nobody:usb"
depend() {
need udev
diff --git a/app-crypt/moolticute/files/moolticuted.init-r1 b/app-crypt/moolticute/files/moolticuted.init-r1
deleted file mode 100644
index 8c4942a34935..000000000000
--- a/app-crypt/moolticute/files/moolticuted.init-r1
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-command=/usr/bin/moolticuted
-command_background="yes"
-pidfile=/var/run/moolticuted.pid
-command_user="nobody:usb"
-
-depend() {
- need udev
-}
diff --git a/app-crypt/moolticute/moolticute-0.43.19-r1.ebuild b/app-crypt/moolticute/moolticute-0.43.19-r1.ebuild
deleted file mode 100644
index ea058a356a20..000000000000
--- a/app-crypt/moolticute/moolticute-0.43.19-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-inherit xdg-utils qmake-utils udev
-
-DESCRIPTION="Mooltipass crossplatform daemon/tools"
-HOMEPAGE="https://github.com/mooltipass/moolticute"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=dev-libs/libusb-1.0.20
- dev-qt/qtdbus:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qttest:5
- dev-qt/qtwebsockets:5
- dev-qt/qtwidgets:5
-"
-BDEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- default
-
- # Fill version.h with package version
- if [[ ${PV} != 9999* ]]; then
- sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
- fi
-}
-
-src_configure() {
- eqmake5 PREFIX="/usr" Moolticute.pro
-}
-
-src_install() {
- emake install INSTALL_ROOT="${D}"
-
- udev_dorules "${FILESDIR}/50-mooltipass.rule"
- newinitd "${FILESDIR}/moolticuted.init-r1" moolticuted
-}
-
-pkg_postinst() {
- udev_reload
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/app-crypt/moolticute/moolticute-0.43.19.ebuild b/app-crypt/moolticute/moolticute-0.43.19-r2.ebuild
index b4fd0cdb9d53..d7fa4843bf98 100644
--- a/app-crypt/moolticute/moolticute-0.43.19.ebuild
+++ b/app-crypt/moolticute/moolticute-0.43.19-r2.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit qmake-utils systemd udev xdg-utils
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
inherit git-r3
else
- SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
fi
-inherit xdg-utils qmake-utils udev
-
DESCRIPTION="Mooltipass crossplatform daemon/tools"
HOMEPAGE="https://github.com/mooltipass/moolticute"
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
+IUSE="systemd"
RDEPEND="
>=dev-libs/libusb-1.0.20
@@ -29,13 +29,13 @@ RDEPEND="
dev-qt/qttest:5
dev-qt/qtwebsockets:5
dev-qt/qtwidgets:5
+ systemd? ( sys-apps/systemd )
+ !systemd? ( sys-apps/systemd-utils )
"
BDEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"
-S="${WORKDIR}/${P/_/-}"
-
src_prepare() {
default
@@ -52,7 +52,8 @@ src_configure() {
src_install() {
emake install INSTALL_ROOT="${D}"
- udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ udev_dorules "${FILESDIR}/50-mooltipass.rules"
+ systemd_dounit systemd/moolticuted.service
newinitd "${FILESDIR}/moolticuted.init" moolticuted
}
@@ -62,5 +63,6 @@ pkg_postinst() {
}
pkg_postrm() {
+ udev_reload
xdg_icon_cache_update
}