summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-05-11 12:46:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-05-11 12:46:57 -0500
commitc928a9e1e28a7e63a471218c846fa4f269395a16 (patch)
treeaddfea5decc2ea83a664006a42d7a0bbd6872ed5
parentgames-strategy/s25rttr: fix GCC 11 build (diff)
downloadgentoo-c928a9e1e28a7e63a471218c846fa4f269395a16.tar.gz
gentoo-c928a9e1e28a7e63a471218c846fa4f269395a16.tar.bz2
gentoo-c928a9e1e28a7e63a471218c846fa4f269395a16.zip
app-admin/github-backup-utils: 3.0.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-admin/github-backup-utils/Manifest1
-rw-r--r--app-admin/github-backup-utils/github-backup-utils-3.0.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/github-backup-utils/Manifest b/app-admin/github-backup-utils/Manifest
index 1451a343fdfc..0d3f9532f640 100644
--- a/app-admin/github-backup-utils/Manifest
+++ b/app-admin/github-backup-utils/Manifest
@@ -1 +1,2 @@
DIST github-backup-utils-2.22.0.tar.gz 102576 BLAKE2B ce9007c8a5d2843ccc2b3d11b03c13840b89d6ae7906d63420cc0e18191766c92c91e1072723439610ae8bdfdd0174601d1e3b7211cd6a1c9a748f9f793ff760 SHA512 e77b4afc6f90b16caf61dc4313787dab0751590b4819dca2d7e21acd0ca774d19ea359171b76f2892ca0fb4f86fd4240e77b00e107de79d496fea429fb12cee8
+DIST github-backup-utils-3.0.0.tar.gz 104088 BLAKE2B f01229e6b152231eb832dec8bef41bb158cc200bbdd3c59c1abab299c572902efe6d27d093491bd8b0bf8f3e834d2938eb0127d5f28700ba75dcbdbcc8a21bb8 SHA512 e86420ef9d86d44560e27e00361ff1bb8ba7c15fb116ad9981e3196bc4c7c25bcff9a9f7dc8dae9bbbb9b2f3380b434199dbbe1ef7db5b1ba04ec1233aec320d
diff --git a/app-admin/github-backup-utils/github-backup-utils-3.0.0.ebuild b/app-admin/github-backup-utils/github-backup-utils-3.0.0.ebuild
new file mode 100644
index 000000000000..d50a44c1f6fb
--- /dev/null
+++ b/app-admin/github-backup-utils/github-backup-utils-3.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python3 support: https://github.com/github/backup-utils/pull/627
+PYTHON_COMPAT=(python3_{7,8,9})
+inherit python-any-r1
+
+DESCRIPTION="Backup and recovery utilities for GitHub Enterprise"
+HOMEPAGE="https://github.com/github/backup-utils"
+SRC_URI="https://github.com/github/backup-utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moreutils parallel is now used for speedups in main code:
+# https://github.com/github/backup-utils/pull/635
+RDEPEND="net-misc/rsync
+ sys-apps/moreutils"
+
+# tests invoke parallel & rsync
+DEPEND="test? (
+ ${RDEPEND}
+ dev-util/checkbashisms
+ ${PYTHON_DEPS}
+)"
+
+MY_PN="${PN/#github-/}"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ dobin bin/*
+ insinto usr/share/${PN}
+ doins share/${PN}/version
+
+ exeinto usr/share/${PN}
+ doexe share/${PN}/bm.sh
+ doexe share/${PN}/ghe-*
+
+ insinto etc/${PN}
+ newins backup.config-example backup.config
+
+ dodoc -r docs/*
+}
+
+src_test() {
+ emake test
+}