summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-07-21 15:57:05 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-07-21 15:57:20 -0700
commitcaebf264af2fe6db271ab5c23dd4c94a2b5f3e4f (patch)
treef1ac208f692ea8a4fab8b311f81ffe61088aea5e
parentdev-python/findpython: new package, add 0.3.1 (diff)
downloadgentoo-caebf264af2fe6db271ab5c23dd4c94a2b5f3e4f.tar.gz
gentoo-caebf264af2fe6db271ab5c23dd4c94a2b5f3e4f.tar.bz2
gentoo-caebf264af2fe6db271ab5c23dd4c94a2b5f3e4f.zip
dev-python/pdm: new package, add 2.8.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pdm/Manifest1
-rw-r--r--dev-python/pdm/metadata.xml15
-rw-r--r--dev-python/pdm/pdm-2.8.0.ebuild69
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
new file mode 100644
index 000000000000..7806eda5507d
--- /dev/null
+++ b/dev-python/pdm/Manifest
@@ -0,0 +1 @@
+DIST pdm-2.8.0.tar.gz 3069029 BLAKE2B 3fc3246c7bf26953be96def58d8249c981def96e1607b82b35f1b8347dc5246dd6b4613e4f2093e2e6453724e8709951d2fff38a1f02f2dcc5e85fe6e8c678da SHA512 95cc0a4cb032fa39281aea5ab2f31da7f503c6444a9c41d88ac9bf9ab650654a3f154506f2ed822e70266046c4b6a111518ed68aa7ab75aa31c096e071859bcd
diff --git a/dev-python/pdm/metadata.xml b/dev-python/pdm/metadata.xml
new file mode 100644
index 000000000000..dc753739c79d
--- /dev/null
+++ b/dev-python/pdm/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pdm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pdm/pdm-2.8.0.ebuild b/dev-python/pdm/pdm-2.8.0.ebuild
new file mode 100644
index 000000000000..af490a26b277
--- /dev/null
+++ b/dev-python/pdm/pdm-2.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/unearth[${PYTHON_USEDEP}]
+ dev-python/findpython[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -a disable_tests=(
+ # tests that try to reach out to the internet
+ basic_integration
+ build_with_no_isolation
+ search_package
+ show_package_on_pypi
+ show_update_hint
+ build_single_module
+ project_packages_path
+ build_package
+ build_src_package
+ build_with_config_settings
+ cli_build_with_config_settings
+ build_ignoring_pip_environment
+ publish_and_build_in_one_run
+ )
+
+ local textexpr
+ testexpr=$(printf 'not %s and ' "${disable_tests[@]}")
+ epytest -m "not network and not integration and not path" -k "${testexpr%and }" -x
+}