summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-05-03 09:21:55 +0000
committerLouis Sautier <sbraz@gentoo.org>2023-05-03 13:09:52 +0200
commitcb382e38e3129700e0672a926806545fff5c9c5a (patch)
tree8dab82004b4d0860754c5936cd4ed3c9062fa3c7
parentdev-util/librnp: Keyword 0.17.0 x86, #905649 (diff)
downloadgentoo-cb382e38e3129700e0672a926806545fff5c9c5a.tar.gz
gentoo-cb382e38e3129700e0672a926806545fff5c9c5a.tar.bz2
gentoo-cb382e38e3129700e0672a926806545fff5c9c5a.zip
www-misc/urlwatch: add 2.28
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30852 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.28.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 4e209c89eb91..90ff2c438858 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1,4 @@
DIST urlwatch-2.24.tar.gz 141175 BLAKE2B 7868ba757493c97ef65136d3da67ef3bb6b0d62e52ab150e169d66adea420872990527a622d305bd14923ff367041d615dcea1495871258040ec2cbb73ee7613 SHA512 ed84cb69ecd8894851c3be0165edfa1dfee92a0b49ea1383e4cfd7c31eb0604f99b1a90d9508753064b58bdd8fc4c0369d817303858d07562b37c3f2ac4cae52
DIST urlwatch-2.25.tar.gz 168241 BLAKE2B 85f76e849495f5457f43ccd37035aae84c6ae4c8649005e617a6a585bf3b73d30914f8c7a89c0fb9bb04cc07a8797d77be07807e8d7c64976355749417b39e40 SHA512 af14c5b4e11345e56e6f326c114629f1e074215d6cc66d9c642424b2a689dc80339157f1b2547fdbe7b7a13d520e2b83bf23c7477da4ae4e43d108e6452624ca
DIST urlwatch-2.26.tar.gz 174305 BLAKE2B c7990b0ecca8bb18632ba717dabfed3e3cdf147ff463e1221c4f7002fcb862d162421ac927bd6a570369a1833268cc08668e284e425e954a4eea8d41cb30eafd SHA512 df214e3576dcbc8f18338a17f890e53ce9142fb98ea5042567eb415e697ee1a19d40b00404a40c0cc4aaaaa35ff3d838d9e0273a6bfe5178059560723ef6e4ca
+DIST urlwatch-2.28.tar.gz 306929 BLAKE2B 73fcff8c153db472c944d0c9406e0e98bf64299d5532486a08cb024339544f17d716a22d6f0807ba55c79af9dc7fef41fa8dc5a7fe79c831f3e9958e3ea8958e SHA512 21a662006dc92c0c636ef0beebc4f2ec90b82182aa0ba94a3348026c2c001b6d74198a14c198f681c8e773b640b6030b63de1a081984ea4d1bbc1e2648bc4161
diff --git a/www-misc/urlwatch/urlwatch-2.28.ebuild b/www-misc/urlwatch/urlwatch-2.28.ebuild
new file mode 100644
index 000000000000..02b7d52bcb99
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.28.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="
+ https://thp.io/2008/urlwatch/
+ https://github.com/thp/urlwatch/
+ https://pypi.org/project/urlwatch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/minidb-2.0.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/tesseract[png]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jq[${PYTHON_USEDEP}]
+ dev-python/pytesseract[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/alabaster
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf]"
+ # Skip code quality check
+ "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
+)
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/jq; then
+ elog "Install 'dev-python/jq' to enable jq filtering support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ if ! has_version dev-python/pytesseract; then
+ elog "Install 'dev-python/pytesseract' to enable OCR support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}