summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 12:49:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 13:06:39 +0200
commitcb8c91474b0ae2f9e889f89afe2d9114dbd1784f (patch)
tree9bd20eec17c85e43701a83311a41b741b488aa40
parentskel.ebuild: Use relative paths for directories. (diff)
downloadgentoo-cb8c91474b0ae2f9e889f89afe2d9114dbd1784f.tar.gz
gentoo-cb8c91474b0ae2f9e889f89afe2d9114dbd1784f.tar.bz2
gentoo-cb8c91474b0ae2f9e889f89afe2d9114dbd1784f.zip
app-office/skrooge: Fix missing header with Frameworks 5.61
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-office/skrooge/files/skrooge-2.20.0-missing-header.patch24
-rw-r--r--app-office/skrooge/skrooge-2.20.0.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/app-office/skrooge/files/skrooge-2.20.0-missing-header.patch b/app-office/skrooge/files/skrooge-2.20.0-missing-header.patch
new file mode 100644
index 000000000000..311404993b84
--- /dev/null
+++ b/app-office/skrooge/files/skrooge-2.20.0-missing-header.patch
@@ -0,0 +1,24 @@
+From 79aeb3f4d3cc01761d99af5868c7fb5101cf2258 Mon Sep 17 00:00:00 2001
+From: Luca Beltrame <lbeltrame@kde.org>
+Date: Sun, 21 Jul 2019 09:19:40 +0200
+Subject: Fix build with Qt 5.13
+
+---
+ plugins/generic/skg_monthly/grantlee_filters/skgdocumentfilter.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/plugins/generic/skg_monthly/grantlee_filters/skgdocumentfilter.cpp b/plugins/generic/skg_monthly/grantlee_filters/skgdocumentfilter.cpp
+index 423eb3a..dfcfb43 100644
+--- a/plugins/generic/skg_monthly/grantlee_filters/skgdocumentfilter.cpp
++++ b/plugins/generic/skg_monthly/grantlee_filters/skgdocumentfilter.cpp
+@@ -27,6 +27,8 @@
+ #include "skgmainpanel.h"
+ #include "skgtraces.h"
+
++#include <QMetaProperty>
++
+ #include <KFormat>
+
+ QVariant SKGDocumentTableFilter::doFilter(const QVariant& input, const QVariant& argument, bool autoescape) const
+--
+cgit v1.1
diff --git a/app-office/skrooge/skrooge-2.20.0.ebuild b/app-office/skrooge/skrooge-2.20.0.ebuild
index 191abf9bd101..998ef8d2ee9a 100644
--- a/app-office/skrooge/skrooge-2.20.0.ebuild
+++ b/app-office/skrooge/skrooge-2.20.0.ebuild
@@ -75,6 +75,8 @@ RDEPEND="${COMMON_DEPEND}
$(add_qt_dep qtquickcontrols)
"
+PATCHES=( "${FILESDIR}"/${P}-missing-header.patch )
+
# hangs + installs files
RESTRICT+=" test"