summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-05-15 11:25:47 -0400
committerMatt Turner <mattst88@gentoo.org>2024-05-15 11:29:08 -0400
commitce0c4015c50aa20afb29624d21c1174fa33f9f27 (patch)
tree79095f9c47ee6256d3ffefc2b83a5d819d293376
parentsys-fs/xfsprogs: call udev_reload (diff)
downloadgentoo-ce0c4015c50aa20afb29624d21c1174fa33f9f27.tar.gz
gentoo-ce0c4015c50aa20afb29624d21c1174fa33f9f27.tar.bz2
gentoo-ce0c4015c50aa20afb29624d21c1174fa33f9f27.zip
app-shells/fzf: Version bump to 0.52.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.52.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index e969e80e334f..2560bac7d9ce 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -6,3 +6,5 @@ DIST fzf-0.49.0-deps.tar.xz 17668152 BLAKE2B 3f5c16b10c7605dec7b775df6c5d4e7dca1
DIST fzf-0.49.0.tar.gz 264849 BLAKE2B 24a51f49384e2c45746181156de20fdb3c8e31c9b1e9bdc9866ba92f654d66b62e3a29afdce794bb23bba441591ab79737ef05716b34a13a76cce66bf24de02b SHA512 fe9d380e1fba460a45ce70a3b44681454833243881a133108f9087a204b1adaafae7bc13e083d25bc783eedb7d4998d5f2301c87f981c0368d081f7f60107fe8
DIST fzf-0.51.0-deps.tar.xz 17657716 BLAKE2B edca4dfdd2030bc3dd1564c3eef81d50d219b7c24da195e3cfce7bb079d7ee2676964fbae60f6ec04f46e5bcfc880c524b97c043cc6cfcd2e8e76b967939bb11 SHA512 155a4695c6acf9cff416752c4ed8f6cd3ff00d1ae48e988cd95eb58fd4cb93cc4db2cdb9464d2fa26277fc9fd26584d398f4bd9681e6aee9e68c3039709c0fbe
DIST fzf-0.51.0.tar.gz 273767 BLAKE2B 96a481ef3e71a201fc94ef554f7aaae80ad62b2961a2403fa1a3c5883d79d9bec61c58c71a205c2d63b78742af23e16a82da91da800482bb8d9c85f6a3b3d149 SHA512 deb9c434764571eeab466898e1c782ff2fdeedc112f449c6d03e42f1b6fd3f8ee3c83252190f099ab030768920148144fb9c73840c6e36d43dad42b004045e65
+DIST fzf-0.52.1-deps.tar.xz 18022516 BLAKE2B d6b5b5075409e7078958735ccc92b34dbed564a7e71019304d30b172bd44ace4a410a07d5ca259626ab5419ba9167b61b48ad94cf00a207ed5e512cb64e2ca7f SHA512 f0677af64ededb668f429c5e8547b22f37646c0a37ca17ec94ca92cf3a18199ddfb341df0626edcfcc27718d42903f2676559b53ae283ba57504fb83f116b05f
+DIST fzf-0.52.1.tar.gz 274817 BLAKE2B a42e694ab3a34025ecee5343e8eeb43221f66989fe6c7b827ad36d60a980c8fcea8414fffbed6858c7eec4d0e54ccc2165eafc5aecd8292d91e05da04bda1f6f SHA512 90b70c0fff41605ca647b02b64a6906e113e6cc377a51db8771806da58463ab87512294b430243b0263a3e800d64e652b6b2580b0b8205890f235d3b64c5e763
diff --git a/app-shells/fzf/fzf-0.52.1.ebuild b/app-shells/fzf/fzf-0.52.1.ebuild
new file mode 100644
index 000000000000..29107a6ca464
--- /dev/null
+++ b/app-shells/fzf/fzf-0.52.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=62963dcefd6d74510ae2692cd0955177bae57543
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}