summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2022-07-23 21:46:09 +1000
committerMark Wright <gienah@gentoo.org>2022-07-23 22:03:20 +1000
commitcec856cb6e99fb0bb31cba9d6c5894885c69de15 (patch)
tree7d78f31ffac838592e6cf664d48b1e37f45b60af
parentdev-qt/qtsvg: Bump to QT5_KDEPATCHSET_REV=2 (diff)
downloadgentoo-cec856cb6e99fb0bb31cba9d6c5894885c69de15.tar.gz
gentoo-cec856cb6e99fb0bb31cba9d6c5894885c69de15.tar.bz2
gentoo-cec856cb6e99fb0bb31cba9d6c5894885c69de15.zip
dev-haskell/http: Bump to 4000.3.16 and 4000.4.1
Closes: https://bugs.gentoo.org/860228 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--dev-haskell/http/Manifest3
-rw-r--r--dev-haskell/http/http-4000.3.16.ebuild (renamed from dev-haskell/http/http-4000.3.14.ebuild)36
-rw-r--r--dev-haskell/http/http-4000.4.1.ebuild47
-rw-r--r--dev-haskell/http/metadata.xml14
4 files changed, 65 insertions, 35 deletions
diff --git a/dev-haskell/http/Manifest b/dev-haskell/http/Manifest
index 773b7c36d1ff..164f7277ddc0 100644
--- a/dev-haskell/http/Manifest
+++ b/dev-haskell/http/Manifest
@@ -1 +1,2 @@
-DIST HTTP-4000.3.14.tar.gz 72938 BLAKE2B d1e24a693d5a63d6ff493766e959447e29c6371854360645f398e4b17f807de3d1ffc4716136fcaeb60f4157bd7622b3d8c30269a98ad7ebecf5f3521e292c03 SHA512 bcc9107412f3ff5806369675ae6cfd87c4ecc36490eab6d62c697f47e62ff8b0d1d6a25f9bfb9d8ef1f037492820eb732cb9cbec7ea9e7e4b20699573077b064
+DIST HTTP-4000.3.16.tar.gz 74516 BLAKE2B a02f66ac69f3e039e465744876b53b94791ca556c90dd13486ccc38138167ef66dedbe985615b62a2a66304b3970643fed4dd268ae9ada2619d373021bd2da97 SHA512 b5136b55967d4db7569a0269b429c8e419878acc548d962af94efa5aa0ddbb8a6ab22bc3096ce3d78b61dc708996c408d4bfa55c6c7fb6c0d915389503cbd755
+DIST HTTP-4000.4.1.tar.gz 74330 BLAKE2B a4efc62f565609efb981c32961ad9fec28246fc67bbbc3da2c8430b7f4c2a96ee378b12b4f6f5f268353db870949cc6b04a9d8489c8f2bee70d783651a2bafc5 SHA512 c1edc529032013391263bcc0f8abd9534fc53a617b5033dfdc478318465cd988732b2644c7144979156c62bd1a08b1ace507b4fb4e2806f22ec7696cbdfd0147
diff --git a/dev-haskell/http/http-4000.3.14.ebuild b/dev-haskell/http/http-4000.3.16.ebuild
index c2e843e563e2..858fd331b35f 100644
--- a/dev-haskell/http/http-4000.3.14.ebuild
+++ b/dev-haskell/http/http-4000.3.16.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23,+network-uri,-conduit10
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
MY_PN="HTTP"
MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
@@ -19,19 +20,13 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="conduit10 +network-uri"
-
-RESTRICT=test # requires network
-RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
- >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
- !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
+ >=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
>=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.7
>=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
@@ -40,20 +35,11 @@ DEPEND="${RDEPEND}
>=dev-haskell/test-framework-hunit-0.3.0 <dev-haskell/test-framework-hunit-0.4 )
"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'base >= 4.3.0.0 && < 4.14' 'base >= 4.3.0.0'
-}
-
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag conduit10 conduit10) \
+ --flag=-conduit10 \
--flag=-mtl1 \
- $(cabal_flag network-uri network-uri) \
+ --flag=network-uri \
--flag=-network23 \
--flag=-old-base \
--flag=-warn-as-error \
diff --git a/dev-haskell/http/http-4000.4.1.ebuild b/dev-haskell/http/http-4000.4.1.ebuild
new file mode 100644
index 000000000000..cf5e8423a02d
--- /dev/null
+++ b/dev-haskell/http/http-4000.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+#hackport: flags: -warp-tests,-mtl1,-warn-as-error,-old-base,-network23,+network-uri,-conduit10
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/httpd-shed-0.4 <dev-haskell/httpd-shed-0.5
+ >=dev-haskell/hunit-1.2.0.1 <dev-haskell/hunit-1.7
+ >=dev-haskell/puremd5-0.2.4 <dev-haskell/puremd5-2.2
+ >=dev-haskell/split-0.1.3 <dev-haskell/split-0.3
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.3.0 <dev-haskell/test-framework-hunit-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-conduit10 \
+ --flag=-mtl1 \
+ --flag=network-uri \
+ --flag=-network23 \
+ --flag=-old-base \
+ --flag=-warn-as-error \
+ --flag=-warp-tests
+}
diff --git a/dev-haskell/http/metadata.xml b/dev-haskell/http/metadata.xml
index b45d3251d695..35fde4e13547 100644
--- a/dev-haskell/http/metadata.xml
+++ b/dev-haskell/http/metadata.xml
@@ -10,19 +10,19 @@
HTTP connections, transmitting requests and processing the responses coming back, all
from within the comforts of Haskell. It's dependent on the network package to operate,
but other than that, the implementation is all written in Haskell.
-
+
A basic API for issuing single HTTP requests + receiving responses is provided. On top
of that, a session-level abstraction is also on offer (the @BrowserAction@ monad);
it taking care of handling the management of persistent connections, proxies,
state (cookies) and authentication credentials required to handle multi-step
interactions with a web server.
-
+
The representation of the bytes flowing across is extensible via the use of a type class,
letting you pick the representation of requests and responses that best fits your use.
Some pre-packaged, common instances are provided for you (@ByteString@, @String@.)
-
+
Here's an example use:
-
+
&gt;
&gt; do
&gt; rsp &lt;- Network.HTTP.simpleHTTP (getRequest "http://www.haskell.org/")
@@ -35,13 +35,9 @@
&gt; request $ getRequest "https://google.com/"
&gt; fmap (take 100) (getResponseBody rsp)
&gt;
-
+
Git repository available at &lt;https://github.com/haskell/HTTP.git&gt;
</longdescription>
- <use>
- <flag name="conduit10">Use version 1.0.x or below of the conduit package (for the test suite).</flag>
- <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
- </use>
<upstream>
<remote-id type="github">haskell/HTTP</remote-id>
</upstream>