summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-22 20:22:04 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-22 20:24:35 -0500
commitcfaf2aad0f3fc6867c445bece6041adfcaa8377f (patch)
tree4d0d7d3ff459457c01d8ff433b0d0ac7ca230a3b
parentapp-shells/gentoo-zsh-completions: repo moved to the gentoo org (diff)
downloadgentoo-cfaf2aad0f3fc6867c445bece6041adfcaa8377f.tar.gz
gentoo-cfaf2aad0f3fc6867c445bece6041adfcaa8377f.tar.bz2
gentoo-cfaf2aad0f3fc6867c445bece6041adfcaa8377f.zip
games-action/garden: fix compile (bug #572648)
Package-Manager: portage-2.2.26
-rw-r--r--games-action/garden/files/garden-1.0.9-gcc52.patch20
-rw-r--r--games-action/garden/garden-1.0.9.ebuild7
2 files changed, 5 insertions, 22 deletions
diff --git a/games-action/garden/files/garden-1.0.9-gcc52.patch b/games-action/garden/files/garden-1.0.9-gcc52.patch
deleted file mode 100644
index 60f927217c6e..000000000000
--- a/games-action/garden/files/garden-1.0.9-gcc52.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/stuff.c.old 2015-09-22 08:57:21.482794770 +0200
-+++ src/stuff.c 2015-09-22 08:58:22.567815095 +0200
-@@ -52,7 +52,7 @@
- float cos_table[ANGLE_1];
- float sin_table[ANGLE_1];
-
--inline int xpart (int angle, int length);
-+extern inline int xpart (int angle, int length);
-
- void init_trig (void)
- {
-@@ -72,7 +72,7 @@
- return (cos_table[angle & 1023] * length);
- }
-
--inline int ypart (int angle, int length)
-+extern inline int ypart (int angle, int length)
- {
- return (sin_table[angle & 1023] * length);
- }
diff --git a/games-action/garden/garden-1.0.9.ebuild b/games-action/garden/garden-1.0.9.ebuild
index 63eb620271a3..39f6086349d2 100644
--- a/games-action/garden/garden-1.0.9.ebuild
+++ b/games-action/garden/garden-1.0.9.ebuild
@@ -20,8 +20,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-dash.patch \
- "${FILESDIR}"/${P}-resources.patch \
- "${FILESDIR}"/${P}-gcc52.patch
+ "${FILESDIR}"/${P}-resources.patch
+ # build with gcc52
+ sed -i \
+ -e 's/inline/extern inline/' \
+ src/stuff.h || die
eautoreconf
}