summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-18 07:26:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-18 07:51:59 +0100
commitcfe7568ff4d057342cdf919724adac484e5a8e14 (patch)
tree749582c11d6ddac50c56f18c8cfd53e2e6e72f91
parentdev-python/ini2toml: Bump to 0.12 (diff)
downloadgentoo-cfe7568ff4d057342cdf919724adac484e5a8e14.tar.gz
gentoo-cfe7568ff4d057342cdf919724adac484e5a8e14.tar.bz2
gentoo-cfe7568ff4d057342cdf919724adac484e5a8e14.zip
dev-python/pyphen: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyphen/Manifest1
-rw-r--r--dev-python/pyphen/pyphen-0.14.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index 8ecaa5b7812f..1033d7676f89 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1,2 @@
DIST pyphen-0.13.2.gh.tar.gz 1998017 BLAKE2B 7290cf7902a3dcfc9355d39de40a13b7aea20252636bdcdcd70436f59ca493dd287f96f365323c3e2d45dfc989e5418db4e3fb676602d123182c33b715ac7d26 SHA512 63bd3411c3120e73cd484eef3c3a280e9f8fee40f9aaf3fdca46c3ddf545aeb462eb4214fb239bd6a1fb6c065d5a34290f39763985e85447f413fc0af0afdae8
+DIST pyphen-0.14.0.tar.gz 1986988 BLAKE2B 3513ad1c9fbcc05318764f862a01bc4bbd6ad6a86f120ad93f8ff1d2a979984c35554db85943b5b7423f97e44ea933c64a3bf9c90aeb18629d215292466581b6 SHA512 5e242de2ecd5e951b2e1925df724013c14cea14729e8e0c132ab233c82406b37cc8d1d21cbd1edd748811fa6826a79da7a5ff9dfa859315840560cacae523e13
diff --git a/dev-python/pyphen/pyphen-0.14.0.ebuild b/dev-python/pyphen/pyphen-0.14.0.ebuild
new file mode 100644
index 000000000000..0aa510692c18
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.14.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="
+ https://github.com/Kozea/Pyphen/
+ https://pypi.org/project/pyphen/
+"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}