summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-03-11 19:05:21 +0800
committerYixun Lan <dlan@gentoo.org>2023-03-11 19:06:12 +0800
commitd067f3d1e3a7819a2086b5f05ef89d42ba6695eb (patch)
tree779d4e6c8cf3e5102ba806251dac0b15889ced47
parentwww-apps/drupal: drop 9.2.18 (diff)
downloadgentoo-d067f3d1e3a7819a2086b5f05ef89d42ba6695eb.tar.gz
gentoo-d067f3d1e3a7819a2086b5f05ef89d42ba6695eb.tar.bz2
gentoo-d067f3d1e3a7819a2086b5f05ef89d42ba6695eb.zip
sys-apps/tuned: add 2.20.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--sys-apps/tuned/Manifest1
-rw-r--r--sys-apps/tuned/tuned-2.20.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/tuned/Manifest b/sys-apps/tuned/Manifest
index 240dd15019d0..8a28800c136e 100644
--- a/sys-apps/tuned/Manifest
+++ b/sys-apps/tuned/Manifest
@@ -1,2 +1,3 @@
DIST tuned-2.18.0.tar.gz 218252 BLAKE2B 25bf078ea4e616830fa8b125251e24afbe2a566fcdd1050b2e1ac95125e22e8276b61f23a0236380bf1aec5ce892e1832230a800356460b5af21346c8825269d SHA512 9508bfad6502b7b9a72fb84d29308cbc10b3cb663b367c821e79ad4d57c2349086c199bf884440c46d230d08d0ad3df17d4f31ebdc03b68c7ba2695b6e18bcc9
DIST tuned-2.19.0.tar.gz 233481 BLAKE2B 9bbd759af69938c8a31b0bb7d746b54f035dc11e3fad2bf8e77d4b318e01f59f51af1d8a5bb8105bdbd9a1393932a27fa2664f529121c956081e92a5f96e2e45 SHA512 64ed338398f7ae73cdf4de04ce24dec6869abf3f399459f13de792edfd965da4efdab0fb1337749556f2868d1769dcb55df9e13983d1e0bc2769fb5fc791cfb8
+DIST tuned-2.20.0.tar.gz 241286 BLAKE2B 0057f41221dcf076c30cf1366cb94ffcc000d08b23f88c2af2488fee4cb43b2f06d0fdcd15d21c1984e08d0d8b31a1ee64029cf36cd3f398d3541f6ff327dc8c SHA512 c8b9fc5bdc684b3c518267875b3757fce5d607bec0df7946fe3a7d345683ea0baa2f8b9bbfb741083b82fd9ca7c825506ca86ea530551837b42c11b45f24ccea
diff --git a/sys-apps/tuned/tuned-2.20.0.ebuild b/sys-apps/tuned/tuned-2.20.0.ebuild
new file mode 100644
index 000000000000..3be0719a79c1
--- /dev/null
+++ b/sys-apps/tuned/tuned-2.20.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit optfeature python-single-r1 tmpfiles xdg-utils
+
+DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
+HOMEPAGE="https://github.com/redhat-performance/tuned"
+SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-linux-procfs[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ ')"
+
+RDEPEND="
+ ${DEPEND}
+ app-emulation/virt-what
+ dev-util/systemtap
+ sys-apps/dbus
+ sys-apps/ethtool
+ sys-power/powertop
+ "
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^PYTHON/s:/usr/bin/python3:${EPREFIX}/usr/bin/${EPYTHON}:" \
+ -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
+ -e "/\$(DESTDIR)\/run\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
+ -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
+ Makefile || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ python_fix_shebang "${D}"
+ python_optimize
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+ xdg_icon_cache_update
+
+ optfeature_header
+ optfeature "Optimize for power saving by spinning-down rotational disks" sys-apps/hdparm
+ optfeature "Get hardware info" sys-apps/dmidecode
+ optfeature "Optimize network txqueuelen" sys-apps/iproute2
+}