summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 05:31:17 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 05:46:33 +0100
commitd0a7eea9b3c822d0be35c24a24bd4664376bd4f6 (patch)
treec6c0c4d11b5ecd9c5a55bf48d750603f18802d04
parentdev-python/stripe: Bump to 8.5.0 (diff)
downloadgentoo-d0a7eea9b3c822d0be35c24a24bd4664376bd4f6.tar.gz
gentoo-d0a7eea9b3c822d0be35c24a24bd4664376bd4f6.tar.bz2
gentoo-d0a7eea9b3c822d0be35c24a24bd4664376bd4f6.zip
app-arch/xarchiver: Bump to 0.5.4.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-arch/xarchiver/Manifest1
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.23.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 8d5c6cbc7a21..0b1cd4d49101 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1 +1,2 @@
DIST xarchiver-0.5.4.22.tar.gz 1125943 BLAKE2B 545061ef8dda7b7d0bdf6025536310705548e48d7f60ba4484900882fb97b0c56f3faac97bb64516f6a919d04b8de082175c020951676ee4b4f59ebd1ca93a74 SHA512 e5c773fbe3d29d998e6aa10eca6cfda5a78defe8d4759d95c894b06f00c22900c8c5cca2ab39066904d19ec1c73fd7326ac16c09ca50c4520621e326f3717887
+DIST xarchiver-0.5.4.23.tar.gz 1126908 BLAKE2B 09d2217aa77d553fd9f8436e1336f95160c366318b43ed22b9693f5dd510c59544d95f1cf643046ba443b44de84792a71d6eb115ad5bd04ab33e03c91e00afd4 SHA512 7459b14772205872de275c855c26a992a6a59e773cdaef25f95a44528baf1d1db7b1d1ef8540e0508babd35468f46c96db9610cc12746947ecccd9332bb69a71
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.23.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.23.ebuild
new file mode 100644
index 000000000000..20ec25e39cdf
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.23.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="
+ https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}