summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 17:04:30 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 17:04:30 +0100
commitd2f5cbee1f4ed87c27569c71b5363d52aafd5117 (patch)
tree4d5b14bbc25bc6c3d5f85ee7380c8287fe4103ae
parentdev-python/scandir: treeclean (diff)
downloadgentoo-d2f5cbee1f4ed87c27569c71b5363d52aafd5117.tar.gz
gentoo-d2f5cbee1f4ed87c27569c71b5363d52aafd5117.tar.bz2
gentoo-d2f5cbee1f4ed87c27569c71b5363d52aafd5117.zip
dev-python/urlgrabber: treeclean
Closes: https://bugs.gentoo.org/588060 Closes: https://bugs.gentoo.org/894606 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/urlgrabber/Manifest1
-rw-r--r--dev-python/urlgrabber/files/urlgrabber-4.1.0-skip-test_range.patch11
-rw-r--r--dev-python/urlgrabber/files/urlgrabber-4.1.0-test-mirror-set-thread-daemon.patch10
-rw-r--r--dev-python/urlgrabber/metadata.xml41
-rw-r--r--dev-python/urlgrabber/urlgrabber-4.1.0.ebuild39
-rw-r--r--profiles/package.mask6
6 files changed, 0 insertions, 108 deletions
diff --git a/dev-python/urlgrabber/Manifest b/dev-python/urlgrabber/Manifest
deleted file mode 100644
index c8317e2f5fb0..000000000000
--- a/dev-python/urlgrabber/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST urlgrabber-4.1.0.tar.gz 277537 BLAKE2B 3697cb1d08fe0fa8bc83118e1466d76d1b8aa0375fd895d12f5135850bb5100d1d52b1691b2135a80a4937158c5d362e88777ae9ba58790ad88355f13e679b34 SHA512 43e54656d0ca92f616d49cd90dd6282408d64909848e4bf1c74b3b1eede55ba0c9526d6ea5fa9ae18545b806ef9965130ecf1cb1f5f05d4611db974d3f2aa200
diff --git a/dev-python/urlgrabber/files/urlgrabber-4.1.0-skip-test_range.patch b/dev-python/urlgrabber/files/urlgrabber-4.1.0-skip-test_range.patch
deleted file mode 100644
index 548242fc1894..000000000000
--- a/dev-python/urlgrabber/files/urlgrabber-4.1.0-skip-test_range.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- urlgrabber-urlgrabber-4-1-0/test/test_mirror.py.orig 2020-11-16 06:23:15.874354961 +0100
-+++ urlgrabber-urlgrabber-4-1-0/test/test_mirror.py 2020-11-16 06:23:59.674354944 +0100
-@@ -329,6 +329,8 @@
- self.assertEqual(self.code, 503); del self.code
-
- def test_range(self):
-+ # skip failing test
-+ self.skip()
- 'test client-side processing of HTTP ranges'
- # server does not process ranges
- self.reply = 200, b'OK'
diff --git a/dev-python/urlgrabber/files/urlgrabber-4.1.0-test-mirror-set-thread-daemon.patch b/dev-python/urlgrabber/files/urlgrabber-4.1.0-test-mirror-set-thread-daemon.patch
deleted file mode 100644
index 6d6e8afa6462..000000000000
--- a/dev-python/urlgrabber/files/urlgrabber-4.1.0-test-mirror-set-thread-daemon.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- urlgrabber-urlgrabber-4-1-0/test/test_mirror.py.orig 2020-11-16 18:47:43.724337579 +0100
-+++ urlgrabber-urlgrabber-4-1-0/test/test_mirror.py 2020-11-16 18:47:57.724337574 +0100
-@@ -290,6 +290,7 @@
- self.exit = False
-
- self.thread = threading.Thread(target=server)
-+ self.thread.daemon = True
- self.thread.start()
-
- # create grabber and mirror group objects
diff --git a/dev-python/urlgrabber/metadata.xml b/dev-python/urlgrabber/metadata.xml
deleted file mode 100644
index 812dc00b5e88..000000000000
--- a/dev-python/urlgrabber/metadata.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- A high-level cross-protocol url-grabber.
-
- Using urlgrabber, data can be fetched in three basic ways:
-
- urlgrab(url) copy the file to the local filesystem
- urlopen(url) open the remote file and return a file object (like urllib2.urlopen)
- urlread(url) return the contents of the file as a string
-
-
- When using these functions (or methods), urlgrabber supports the following
- features:
-
- * identical behavior for http://, ftp://, and file:// urls
- * http keepalive - faster downloads of many files by using only a single
- connection
- * byte ranges - fetch only a portion of the file
- * reget - for a urlgrab, resume a partial download
- * progress meters - the ability to report download progress automatically,
- even when using urlopen!
- * throttling - restrict bandwidth usage
- * retries - automatically retry a download if it fails. The number of retries
- and failure types are configurable.
- * authenticated server access for http and ftp
- * proxy support - support for authenticated http and ftp proxies
- * mirror groups - treat a list of mirrors as a single source, automatically
- switching mirrors if there is a failure.
- </longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">urlgrabber</remote-id>
- <remote-id type="github">rpm-software-management/urlgrabber</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild b/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild
deleted file mode 100644
index 08457ee90633..000000000000
--- a/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Python module for downloading files"
-HOMEPAGE="http://urlgrabber.baseurl.org https://github.com/rpm-software-management/urlgrabber"
-SRC_URI="https://github.com/rpm-software-management/${PN}/archive/${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-${PV//./-}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86"
-
-# Entire testsuite relies on connecting to the i'net
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
-"
-BDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-skip-test_range.patch"
- "${FILESDIR}/${P}-test-mirror-set-thread-daemon.patch"
-)
-
-python_test() {
- URLGRABBER_EXT_DOWN="${S}/scripts/urlgrabber-ext-down" \
- PYTHON_PATH="${S}" \
- "${EPYTHON}" test/runtests.py -v 2 || die "Tests failed under ${EPYTHON}"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index b5068fbb2d18..877c42ae9af8 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -275,12 +275,6 @@ dev-python/cov-core
dev-python/pytest-flake8
# Michał Górny <mgorny@gentoo.org> (2023-02-15)
-# A number of test failures, and the test phase does not fail correctly.
-# Last release in 2019. No revdeps.
-# Removal on 2023-03-17. Bug #894606.
-dev-python/urlgrabber
-
-# Michał Górny <mgorny@gentoo.org> (2023-02-15)
# Unmaintained. Broken with current version of dev-python/pyglet.
# No upstream activity since Sep 2021. No revdeps.
# Removal on 2023-03-17. Bug #887973.