summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-30 00:34:25 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-30 00:34:41 +1200
commitd3141832fd1d93a1790f497c5cf4287f03d72c8d (patch)
tree761b616f7c6125c06e0db3c6a41da3f6c9ef71f1
parentapp-editors/texworks: Drop old (diff)
downloadgentoo-d3141832fd1d93a1790f497c5cf4287f03d72c8d.tar.gz
gentoo-d3141832fd1d93a1790f497c5cf4287f03d72c8d.tar.bz2
gentoo-d3141832fd1d93a1790f497c5cf4287f03d72c8d.zip
dev-perl/Audio-WMA: -r bump for EAPI7
- EAPI7 - Use patch instead of sed - Parallel tests - Removed unneeded variable assignments Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild21
-rw-r--r--dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch23
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild b/dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild
new file mode 100644
index 000000000000..d19ed443c9ad
--- /dev/null
+++ b/dev-perl/Audio-WMA/Audio-WMA-1.300.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_VERSION=1.3
+DIST_AUTHOR=DANIEL
+inherit perl-module
+
+DESCRIPTION="extension for reading WMA/ASF metadata"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3-no-dot-inc.patch"
+)
diff --git a/dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch b/dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch
new file mode 100644
index 000000000000..7141ffd645ac
--- /dev/null
+++ b/dev-perl/Audio-WMA/files/Audio-WMA-1.3-no-dot-inc.patch
@@ -0,0 +1,23 @@
+From 59f5c5d6f302c3cacb212048cb7c30b727e03d91 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 30 Apr 2020 00:11:42 +1200
+Subject: Include '.' in @INC on Perl 5.28+
+
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index e607505..51add3f 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,5 +1,5 @@
+ # $Id: Makefile.PL 10 1998-12-16 23:02:45Z daniel $
+-
++use lib '.';
+ use inc::Module::Install;
+
+ name('Audio-WMA');
+--
+2.26.2
+