summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 08:16:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 09:30:07 +0200
commitd3714c80110857d8e8b9c8a713b32fde03df4e0f (patch)
tree3191d422c8c49b2283bd5d04e806eeab8a36d0f1
parentdev-python/Faker: Bump to 18.13.0 (diff)
downloadgentoo-d3714c80110857d8e8b9c8a713b32fde03df4e0f.tar.gz
gentoo-d3714c80110857d8e8b9c8a713b32fde03df4e0f.tar.bz2
gentoo-d3714c80110857d8e8b9c8a713b32fde03df4e0f.zip
dev-python/jaraco-path: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-path/Manifest1
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.7.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
index d4a147f75fb0..0f6bc8260abd 100644
--- a/dev-python/jaraco-path/Manifest
+++ b/dev-python/jaraco-path/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.path-3.5.0.tar.gz 11060 BLAKE2B 54048439d0339618a4a22289ade29144df9f821fd4bf46e037af5e89d3e50a0b6d6bbe76330d9d1e4671dc39c60516022ea436e69673dc000ed668165d9ffc84 SHA512 987391bada099d35050a9238e3420cb7815e0851178f33adfcba873b7a8cb56adcbb9d7d15b77404c2140682200960d46ace2031e8152de0866511120715fcfd
DIST jaraco.path-3.6.0.tar.gz 11029 BLAKE2B 2637579456e2d73860efa28827c51a3b871edcb0f86f8cf2f9af33f962980dd476d570750db408d30781e23d25c82b3645af80cefef3c45fc4da77e3182cd10f SHA512 86560abd4816fe490f7933985d8dd4003a61b6713cfa9dca3ad8e58b176adf01039731f779775a5268de4073e1290ef21f12ad02edfae4617e1d0e641eba4a16
+DIST jaraco.path-3.7.0.tar.gz 11039 BLAKE2B d861cf9af9723d0dd59dff61242c7a5e7de439d0156e4fcc024c30c5cde2773ca0b501527fbade2cae84cc236f74d0e242179a4f51775dbde92cc0c9bed5b267 SHA512 22eba78273da9b354153bb45b2d62d9ba35466f78ad2bf728f4c284d19572443e7267c39008b3fd43b975c9dc258cddf3a3287adddd243e1031d182e6562072a
diff --git a/dev-python/jaraco-path/jaraco-path-3.7.0.ebuild b/dev-python/jaraco-path/jaraco-path-3.7.0.ebuild
new file mode 100644
index 000000000000..4b4767844e98
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}