summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-26 15:28:10 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-26 15:28:54 -0400
commitd5da1d44733e63bc49eb82577f988132aa2b6e97 (patch)
tree4fc2f9acaaaf2a108bb0f38d8edd81a368cd302f
parentsys-kernel/gentoo-sources: Linux patch 4.19.46 (diff)
downloadgentoo-d5da1d44733e63bc49eb82577f988132aa2b6e97.tar.gz
gentoo-d5da1d44733e63bc49eb82577f988132aa2b6e97.tar.bz2
gentoo-d5da1d44733e63bc49eb82577f988132aa2b6e97.zip
dev-python/yapps: remove last-rited package
Closes: https://bugs.gentoo.org/618734 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-python/yapps/Manifest1
-rw-r--r--dev-python/yapps/files/yapps-Convert-print-statements-to-python3-style-print-func.patch46
-rw-r--r--dev-python/yapps/files/yapps-Don-t-capture-sys.stderr-at-import-time.patch32
-rw-r--r--dev-python/yapps/metadata.xml12
-rw-r--r--dev-python/yapps/yapps-2.2.0-r1.ebuild28
-rw-r--r--profiles/package.mask4
6 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/yapps/Manifest b/dev-python/yapps/Manifest
deleted file mode 100644
index cac92db98c09..000000000000
--- a/dev-python/yapps/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Yapps-2.2.0.tar.gz 13630 BLAKE2B b1c3370c0a91febc7ab567fa9af05150f74d19e4de18d09e41ff7e361b06f8bd9aed0ad5ac01f9d1c46bdb381af57cfe11603ebf534b10979a16a5211171a31f SHA512 087f99071b2615f5382f453d9b3492675704aa7e7ff54b332d7c4e337e16fbd3ab3c1b3820a7941775c0b3ecf7e255a7773cb47ea20e8adb77dc3dc8d9a49faa
diff --git a/dev-python/yapps/files/yapps-Convert-print-statements-to-python3-style-print-func.patch b/dev-python/yapps/files/yapps-Convert-print-statements-to-python3-style-print-func.patch
deleted file mode 100644
index 4bff7f8f40dd..000000000000
--- a/dev-python/yapps/files/yapps-Convert-print-statements-to-python3-style-print-func.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From d051588873a54860cfb86ec0d330f7d855336618 Mon Sep 17 00:00:00 2001
-From: Julien Cristau <julien.cristau@logilab.fr>
-Date: Tue, 2 Dec 2014 10:41:05 +0100
-Subject: [PATCH 2/2] Convert print statements to python3-style print function
-
-Signed-off-by: Julien Cristau <julien.cristau@logilab.fr>
----
- yapps/runtime.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/yapps/runtime.py b/yapps/runtime.py
-index 58017fe..5d40581 100644
---- a/yapps/runtime.py
-+++ b/yapps/runtime.py
-@@ -178,7 +178,7 @@ class Scanner(object):
- file,line,p = pos
- if file != self.filename:
- if self.stack: return self.stack.print_line_with_pointer(pos,length=length,out=out)
-- print >>out, "(%s: not in input buffer)" % file
-+ print("(%s: not in input buffer)" % file, file=out)
- return
-
- text = self.input
-@@ -201,7 +201,7 @@ class Scanner(object):
- break
- spos = cr+1
- else:
-- print >>out, "(%s:%d not in input buffer)" % (file,origline)
-+ print("(%s:%d not in input buffer)" % (file,origline), file=out)
- return
-
- # Now try printing part of the line
-@@ -230,8 +230,8 @@ class Scanner(object):
- p = p - 7
-
- # Now print the string, along with an indicator
-- print >>out, '> ',text
-- print >>out, '> ',' '*p + '^'
-+ print('> ',text, file=out)
-+ print('> ',' '*p + '^', file=out)
-
- def grab_input(self):
- """Get more input if possible."""
---
-2.6.4
-
diff --git a/dev-python/yapps/files/yapps-Don-t-capture-sys.stderr-at-import-time.patch b/dev-python/yapps/files/yapps-Don-t-capture-sys.stderr-at-import-time.patch
deleted file mode 100644
index 1e25a0059409..000000000000
--- a/dev-python/yapps/files/yapps-Don-t-capture-sys.stderr-at-import-time.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 482faec17f1c69784d8cc2757a79809458d71154 Mon Sep 17 00:00:00 2001
-From: Julien Cristau <julien.cristau@logilab.fr>
-Date: Tue, 2 Dec 2014 10:40:01 +0100
-Subject: [PATCH 1/2] Don't capture sys.stderr at import time
-
-Signed-off-by: Julien Cristau <julien.cristau@logilab.fr>
----
- yapps/runtime.py | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/yapps/runtime.py b/yapps/runtime.py
-index 29f91e7..58017fe 100644
---- a/yapps/runtime.py
-+++ b/yapps/runtime.py
-@@ -168,10 +168,13 @@ class Scanner(object):
- # output += '%s\n' % (repr(t),)
- # return output
-
-- def print_line_with_pointer(self, pos, length=0, out=sys.stderr):
-+ def print_line_with_pointer(self, pos, length=0, out=None):
- """Print the line of 'text' that includes position 'p',
- along with a second line with a single caret (^) at position p"""
-
-+ if out is None:
-+ out = sys.stderr
-+
- file,line,p = pos
- if file != self.filename:
- if self.stack: return self.stack.print_line_with_pointer(pos,length=length,out=out)
---
-2.6.4
-
diff --git a/dev-python/yapps/metadata.xml b/dev-python/yapps/metadata.xml
deleted file mode 100644
index 335bb8d11a4b..000000000000
--- a/dev-python/yapps/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">Yapps</remote-id>
- <remote-id type="github">smurfix/yapps</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/yapps/yapps-2.2.0-r1.ebuild b/dev-python/yapps/yapps-2.2.0-r1.ebuild
deleted file mode 100644
index ce36d639e2a9..000000000000
--- a/dev-python/yapps/yapps-2.2.0-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-MY_PN="Yapps"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="An easy to use parser generator"
-HOMEPAGE="https://github.com/smurfix/yapps"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-Don-t-capture-sys.stderr-at-import-time.patch"
- epatch "${FILESDIR}/${PN}-Convert-print-statements-to-python3-style-print-func.patch"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index a23337f0f3ba..9147b81b70f1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -338,10 +338,6 @@ net-libs/farstream:0.1
# Removal in 30 days. Bug #683862
dev-python/djangocms-attributes-field
-# Virgil Dupras <vdupras@gentoo.org> (26 Apr 2019)
-# Unmaintained, no revdeps. Removal in 30 days. Bug #618734
-dev-python/yapps
-
# Jason Zaman <perfinion@gentoo.org> (25 Apr 2019)
# net-mail/perdition was last-rited in 2016. The
# SELinux policy packge is no longer needed.