summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-15 08:10:19 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-15 08:48:49 +0200
commitd62d6c07035cf9a3eae03961f860c220fe6cf19c (patch)
treee87be10a8994cd0c6d0f83c55a63bc41ccde66b4
parentdev-libs/spdlog: fix subslot (diff)
downloadgentoo-d62d6c07035cf9a3eae03961f860c220fe6cf19c.tar.gz
gentoo-d62d6c07035cf9a3eae03961f860c220fe6cf19c.tar.bz2
gentoo-d62d6c07035cf9a3eae03961f860c220fe6cf19c.zip
dev-ruby/ox: add 2.14.17
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/ox/Manifest1
-rw-r--r--dev-ruby/ox/ox-2.14.17.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ox/Manifest b/dev-ruby/ox/Manifest
index 73737a1bf4a3..6adc804bb082 100644
--- a/dev-ruby/ox/Manifest
+++ b/dev-ruby/ox/Manifest
@@ -1 +1,2 @@
DIST ox-2.14.16.tar.gz 224723 BLAKE2B 51c8e6d817f6e6fc302ddd6b7cb3a9899a6c7898ef6f602b20accb88b9126e6490a33bb7bb1382a087e05bbe287d5838b5d8652f4f6a96013f5fd4ba619e6075 SHA512 211cbf48fb580c339e57e352991b7be98efc8490ba97b559c61fd573853e26fcba87b7e0e05c720ecab9ef188b9d0d2cbd511620b197c5341c6bdb02370ffcb3
+DIST ox-2.14.17.tar.gz 224636 BLAKE2B 9a8df3430a4eeeb74df1d930caba7ed84a6eacad28515e908781fbea9503f722cf9165e4498367f6838fad60bc976dd6621b69f7036a902a26c75cd6afa3a3bf SHA512 919da1884033af0e44c7dbef78a5d08dc473967bd23a9ab445b295ae57a6f1495cc95ed88794164d96d6f000b9262fa0abce9c8b4b93d27ee4c68997c820f0c1
diff --git a/dev-ruby/ox/ox-2.14.17.ebuild b/dev-ruby/ox/ox-2.14.17.ebuild
new file mode 100644
index 000000000000..8fb552f6375f
--- /dev/null
+++ b/dev-ruby/ox/ox-2.14.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ox.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ox/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/ox
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="https://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}