summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-11 15:16:51 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-11 15:16:51 -0400
commitd64194b301be4f86377379a7b52e71fb657f2c4e (patch)
tree8523a99007ababdd83fbae9976b0d123a2f845b0
parentapp-admin/glance: 18.0.0 allarches stablized (diff)
downloadgentoo-d64194b301be4f86377379a7b52e71fb657f2c4e.tar.gz
gentoo-d64194b301be4f86377379a7b52e71fb657f2c4e.tar.bz2
gentoo-d64194b301be4f86377379a7b52e71fb657f2c4e.zip
app-text/mupdf: fix opengl dependencies
It was a very bad idea from me to remove dependency on freeglut on the account that we use the bundled version. I completely forgot about freeglut dependencies themselves. Bad me. These dependencies, however, are a bit complex and I find it fragile to copy-paste them in mupdf. At the cost of installing an extra system library (freeglut) that is rather small and probably already installed anyways, we potentially save ourselves tricky problems down the road. Closes: https://bugs.gentoo.org/685604 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--app-text/mupdf/mupdf-1.15.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-text/mupdf/mupdf-1.15.0.ebuild b/app-text/mupdf/mupdf-1.15.0.ebuild
index 440a343441f5..7d1f75d3ee14 100644
--- a/app-text/mupdf/mupdf-1.15.0.ebuild
+++ b/app-text/mupdf/mupdf-1.15.0.ebuild
@@ -14,6 +14,9 @@ SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="X +javascript libressl opengl ssl static-libs vanilla"
+# Although we use the bundled, patched version of freeglut in mupdf (because of
+# bug #653298), the best way to ensure that its dependencies are present is to
+# install system's freeglut.
RDEPEND="
media-libs/freetype:2=[static-libs?]
media-libs/harfbuzz:=[static-libs?,truetype]
@@ -21,6 +24,7 @@ RDEPEND="
media-libs/libpng:0=[static-libs?]
>=media-libs/openjpeg-2.1:2=[static-libs?]
virtual/jpeg[static-libs?]
+ opengl? ( >=media-libs/freeglut-3.0.0:= )
ssl? (
libressl? ( >=dev-libs/libressl-2.8:0=[static-libs?] )
!libressl? ( >=dev-libs/openssl-1.1:0=[static-libs?] )