summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-13 16:51:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-16 18:43:29 +0100
commitd6470e173afa9efa781e8c52a48552cfa1ec1fbf (patch)
tree0668c40575417fd184fd95cd2d4b527f7298b375
parentdev-python/pdm-pep517: New NIH build system, v0.10.0 (diff)
downloadgentoo-d6470e173afa9efa781e8c52a48552cfa1ec1fbf.tar.gz
gentoo-d6470e173afa9efa781e8c52a48552cfa1ec1fbf.tar.bz2
gentoo-d6470e173afa9efa781e8c52a48552cfa1ec1fbf.zip
dev-python/flufl-i18n: Bump to 4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flufl-i18n/Manifest1
-rw-r--r--dev-python/flufl-i18n/flufl-i18n-4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/flufl-i18n/Manifest b/dev-python/flufl-i18n/Manifest
index 1699294c6436..3082a73d62ab 100644
--- a/dev-python/flufl-i18n/Manifest
+++ b/dev-python/flufl-i18n/Manifest
@@ -1 +1,2 @@
DIST flufl.i18n-3.2.tar.gz 24209 BLAKE2B dc827eb4099670c6e5c39ebc8702fcda146b20a3978fa56108ab98a05d2c8911e705b71dacd6b9fc7fae9923d009487f6f047baa0dcd06a5de2e4f4d5fafc465 SHA512 07f329d026f24db623045f3c9857bcaacc1f0982066d4409fc060c4f712716044f96321a4e4909cbc85932f36fc76f71b9d118662ba837fd85b22754ce2d25c7
+DIST flufl.i18n-4.0.tar.gz 21119 BLAKE2B 6bd4a311c3df56b03a0d46164f7f1ee1eeeb257478a82515261894f4cdf3017b150f1e13ce95a08f50ed5e01cf736884c7ba05a96e3f6b90917418ed18462753 SHA512 03e953af7e406d24a64d334647008e222cf74e5e055865638a52d8ec7e25edae44046aa4dfa8766b5a1458b335e9e29bd8b3e89703d8c8b28ab777375da19712
diff --git a/dev-python/flufl-i18n/flufl-i18n-4.0.ebuild b/dev-python/flufl-i18n/flufl-i18n-4.0.ebuild
new file mode 100644
index 000000000000..f343ff90edc2
--- /dev/null
+++ b/dev-python/flufl-i18n/flufl-i18n-4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+
+DESCRIPTION="A high level API for Python internationalization"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.i18n"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}