summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-05-29 15:30:19 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-29 15:30:39 +0300
commitd773db27f39839bbb59ca507a3e44be4bf9aa984 (patch)
tree3f51571b7a8f68041b69db029b2915e36ef9bd31
parentapp-editors/scite: add gcc-13 fix from bgo#892431 (diff)
downloadgentoo-d773db27f39839bbb59ca507a3e44be4bf9aa984.tar.gz
gentoo-d773db27f39839bbb59ca507a3e44be4bf9aa984.tar.bz2
gentoo-d773db27f39839bbb59ca507a3e44be4bf9aa984.zip
app-editors/scite: drop 5.1.3, 5.2.4, 5.3.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-editors/scite/Manifest3
-rw-r--r--app-editors/scite/scite-5.1.3.ebuild97
-rw-r--r--app-editors/scite/scite-5.2.4.ebuild97
-rw-r--r--app-editors/scite/scite-5.3.0.ebuild97
4 files changed, 0 insertions, 294 deletions
diff --git a/app-editors/scite/Manifest b/app-editors/scite/Manifest
index 7764d11afc96..89177a5a6bac 100644
--- a/app-editors/scite/Manifest
+++ b/app-editors/scite/Manifest
@@ -1,4 +1 @@
-DIST scite-5.1.3.tgz 3427245 BLAKE2B ca765b61cb1fa96934c1e28d76a97cd7086a6c692ae33bb57591dfbc8637ffc94c4a3f20f9c6b55d11da8a76664f1d521f7e393bf6f31db55cbe02e0bf5052ba SHA512 ef86a18f739062598d3c7bf19bcd2f38ca012e890b9b4685c1f1b809e928762ab60d24c33a1f45ca33133ce5007e3a22a76e80222b121c9a4089d3c57aa0bc4c
-DIST scite-5.2.4.tgz 3440615 BLAKE2B a98028774837f7c19a73d3ceef0e7cf945674b0b0d21eec7af4874a1fab1dcbfdad9255adcfb9d458dfc6549baeb27dee3fab207f0145b6c722794a9a96ec284 SHA512 ac3f25fbfe654f4b249c55b2bf97d5ea57483a484feeb30c3663e13366d1a569d9faa22c83b4eb5201154d00713fcd550478573db987084eba0a2e8ea22c57e9
-DIST scite-5.3.0.tgz 3499449 BLAKE2B b54a4eb5c9d669f840efa782d0b02e1b087b386aabbf58dcd37bdc314f42ff6597bf674329c64bbf40befecbc3d3d00aaf13bd03d0f18a28ab6a050049b25336 SHA512 3401ea04019f4fbbd15118a6b2aeffaaeff91382e742cff4df2dcd83ea59e4d43600b288869db9dbe44609fcfad979d29659edbd200b6b0edfa56eac5a9f577d
DIST scite-5.3.5.tgz 3535798 BLAKE2B 16bd6331b8ab5ef2d700a121d8d85078f6eea2f8c45cfd62c5b27c7c9622f853a871e98402ee3833c09652d869271ed05a61374ee1f55d58dbdcc0f5fcbd681c SHA512 18ed3e802f6f5e66573f72c4ad42d592ea3f79e191e828a32d2d55aaf285a2cb9961e206c9e99f82c77f0975494e9105ac925394d7cf48223b954e253f1dee9c
diff --git a/app-editors/scite/scite-5.1.3.ebuild b/app-editors/scite/scite-5.1.3.ebuild
deleted file mode 100644
index 56eaa7f3c945..000000000000
--- a/app-editors/scite/scite-5.1.3.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-1 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- default
- dosym SciTE /usr/bin/scite
-}
diff --git a/app-editors/scite/scite-5.2.4.ebuild b/app-editors/scite/scite-5.2.4.ebuild
deleted file mode 100644
index 351ecb41df39..000000000000
--- a/app-editors/scite/scite-5.2.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-4 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- GTK3=1 default
- dosym SciTE /usr/bin/scite
-}
diff --git a/app-editors/scite/scite-5.3.0.ebuild b/app-editors/scite/scite-5.3.0.ebuild
deleted file mode 100644
index 351ecb41df39..000000000000
--- a/app-editors/scite/scite-5.3.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-4 )
-
-inherit lua-single toolchain-funcs xdg
-
-DESCRIPTION="A very powerful, highly configurable, small editor with syntax coloring"
-HOMEPAGE="https://www.scintilla.org/SciTE.html"
-SRC_URI="https://www.scintilla.org/${PN}${PV//./}.tgz -> ${P}.tgz"
-
-LICENSE="HPND lua? ( MIT )"
-SLOT="0"
-KEYWORDS="amd64 ppc ~riscv x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/atk
- dev-libs/glib:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
- lua? ( ${LUA_DEPS} )"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig"
-
-DOCS=("../README")
-
-S="${WORKDIR}/${PN}/gtk"
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- tc-export AR CC CXX RANLIB
-
- # remove hardcoded CC, Optimizations and clang unknown flags
- sed -i "${WORKDIR}/scintilla/gtk/makefile" \
- -e "s#^CC = gcc#CC = ${CC}#" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-Os##" \
- -e "s#-Wno-misleading-indentation##" \
- || die "error patching /scintilla/gtk/makefile"
-
- sed -i "${S}/makefile" \
- -e "s#^CC = clang#CC = ${CC}#" \
- -e "s#^CXX = clang++#CXX = ${CXX}#" \
- -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
- -e "s#-Os##" \
- || die "error patching gtk/makefile"
-
- # repair and enhance the .desktop file
- sed -i "${S}/SciTE.desktop" \
- -e "s#text/plain#text/\*;application/xhtml+xml#" \
- -e "s#^Categories=\(.*\)#Categories=Development;#" \
- || die "error patching /scite/gtk/SciTe.desktop"
-
- # add the ebuild suffix as shell type for working with ebuilds
- sed -i "${WORKDIR}/scite/src/perl.properties" \
- -e "s#\*.sh;\*.bsh;#\*.ebuild;\*.sh;\*.bsh;#" \
- || die "error patching /scite/src/perl.properties"
-
- # it seems that pwd here is ${S}, but user patches are relative to ${workdir}
- # Bug #576162
-
- cd "${WORKDIR}" || die "couldn't cd into ${WORKDIR}"
- eapply_user
-}
-
-src_compile() {
- # prepare make options
- local emake_pars=("GTK3=1")
-
- tc-is-clang && emake_pars+=("CLANG=1")
- use !lua && emake_pars+=("NO_LUA=1")
-
- emake -C "${WORKDIR}/lexilla/src" "${emake_pars[@]}"
- emake -C "${WORKDIR}/scintilla/gtk" "${emake_pars[@]}"
- emake "${emake_pars[@]}"
-}
-
-# want to use the base src_install() as base_src_install()
-
-src_install() {
- GTK3=1 default
- dosym SciTE /usr/bin/scite
-}