summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-04-16 22:07:41 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-04-16 22:13:56 +0300
commitd9a4a5917f2c0d2eb0f9b8232d17cc2ccf2884a9 (patch)
treeb86f651cad223e2e3903950b91e1a6b433890e10
parentsys-libs/talloc: drop 2.3.4 (diff)
downloadgentoo-d9a4a5917f2c0d2eb0f9b8232d17cc2ccf2884a9.tar.gz
gentoo-d9a4a5917f2c0d2eb0f9b8232d17cc2ccf2884a9.tar.bz2
gentoo-d9a4a5917f2c0d2eb0f9b8232d17cc2ccf2884a9.zip
dev-games/aseprite: sync filter-lto fix to 1.3.5
- originally made in 95f26136eef6b81d752e4ddf102934306f69c581. Closes: https://github.com/gentoo/gentoo/pull/35619 Co-authored-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-games/aseprite/aseprite-1.3.5.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-games/aseprite/aseprite-1.3.5.ebuild b/dev-games/aseprite/aseprite-1.3.5.ebuild
index fbbe0ad3e3a5..8717c09abd5e 100644
--- a/dev-games/aseprite/aseprite-1.3.5.ebuild
+++ b/dev-games/aseprite/aseprite-1.3.5.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake desktop python-any-r1 toolchain-funcs xdg-utils
+inherit cmake desktop flag-o-matic python-any-r1 toolchain-funcs xdg-utils
SKIA_VER="m102"
# Last commit in ${SKIA_VER} feature branch
@@ -78,7 +78,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.2.35_laf_fixes.patch"
"${FILESDIR}/${PN}-1.3.2_shared_fmt.patch"
"${FILESDIR}/${PN}-1.3.2_strict-aliasing.patch"
- "${FILESDIR}/${PN}-1.3.5_laf-strict-aliasing.patch"
+ "${FILESDIR}"/aseprite-1.3.5_laf-strict-aliasing.patch
)
src_prepare() {
@@ -97,6 +97,19 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing, -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924692
+ # https://github.com/aseprite/aseprite/issues/4413
+ #
+ # There is a bundled skia that fails with ODR errors. When excluding just
+ # skia from testing, aseprite itself failed with strict-aliasing (before
+ # upstream PR#84), and when that is disabled, fails again with ODR and
+ # lto-type-mismatch issues.
+ #
+ # There are a lot of issues, so don't trust any fixes without thorough
+ # testing.
+ filter-lto
+
einfo "Skia configuration"
cd "${WORKDIR}/skia-${SKIA_REV}" || die