summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-01-25 21:00:41 +0530
committerZac Medico <zmedico@gentoo.org>2024-02-01 22:37:26 -0800
commitda4f4f93bcfc2b31d18dbf4460fc6693f59cccea (patch)
tree5a3cd57709e62066b8ea7611b64a0c55cb302ecd
parentapp-containers/containers-image: add 5.29.2 (diff)
downloadgentoo-da4f4f93bcfc2b31d18dbf4460fc6693f59cccea.tar.gz
gentoo-da4f4f93bcfc2b31d18dbf4460fc6693f59cccea.tar.bz2
gentoo-da4f4f93bcfc2b31d18dbf4460fc6693f59cccea.zip
app-containers/containers-common: add 0.57.3
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-containers/containers-common/Manifest1
-rw-r--r--app-containers/containers-common/containers-common-0.57.3.ebuild59
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild3
3 files changed, 61 insertions, 2 deletions
diff --git a/app-containers/containers-common/Manifest b/app-containers/containers-common/Manifest
index 0ea2e1ba8627..ec4699ca6425 100644
--- a/app-containers/containers-common/Manifest
+++ b/app-containers/containers-common/Manifest
@@ -1,2 +1,3 @@
DIST containers-common-0.56.0.tar.gz 12616120 BLAKE2B 6495ca7d0c9134bc8bd5f7b7541bb4f1160c74abb7a64bd4d2124104ea563f5381f0092da20ab45d81929a8632b1fcc1107ac05fdae011be446cff14ebf88c45 SHA512 4af720be95e6b5ca7d0664f99a389bf092b9f45d4e0602d9b49ef1d21b359d2307a94e0c88378fe0c751f5b40db54d7aab67eb497185a289cea9288cbfaa042c
DIST containers-common-0.57.0.tar.gz 12700958 BLAKE2B 8432a7d839b94b59eabd75d4978a4d0c1340a64ed626db74e74a8318e08c61172bfba5e4f4c4b0dfffec302c5a310bb5be8fad3ab4d91a6d89ced373a0a6f297 SHA512 b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3
+DIST containers-common-0.57.3.tar.gz 12702863 BLAKE2B 7842893f9b8ca72fa0657ea716f61cad95c4a8bff680922a15cffad4cecf897683591272fee83494e800023a432458cc689a810726e60e4d5ff9dd6af2d71737 SHA512 f0b7c4632317e666342f7b31bd9e5e9cdc794125d4d358e6a62ba115099ee1e6b33751cff982dcadbb3055b093d05fbd1049402f79ca2e6465cc6fcabce7c928
diff --git a/app-containers/containers-common/containers-common-0.57.3.ebuild b/app-containers/containers-common/containers-common-0.57.3.ebuild
new file mode 100644
index 000000000000..5a0aa2f26d0b
--- /dev/null
+++ b/app-containers/containers-common/containers-common-0.57.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common config files and docs for Containers stack"
+HOMEPAGE="https://github.com/containers/common"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/common.git"
+else
+ SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ app-containers/containers-image
+ app-containers/containers-storage
+ app-containers/containers-shortnames
+ net-firewall/nftables
+ net-firewall/iptables[nftables]
+ || ( app-containers/crun app-containers/runc )
+ || (
+ ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
+ >=app-containers/cni-plugins-0.9.1
+ )
+"
+
+BDEPEND="
+ >=dev-go/go-md2man-2.0.3
+"
+
+src_prepare() {
+ default
+
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
+
+ # add comments to mounts.conf
+ eapply "${FILESDIR}/examplify-mounts-conf.patch"
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /usr/share/containers
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
+
+ keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
+}
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index 5eca915dd606..5a0aa2f26d0b 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -22,7 +22,6 @@ RDEPEND="
app-containers/containers-image
app-containers/containers-storage
app-containers/containers-shortnames
- !<app-containers/podman-4.5.0-r1
net-firewall/nftables
net-firewall/iptables[nftables]
|| ( app-containers/crun app-containers/runc )
@@ -33,7 +32,7 @@ RDEPEND="
"
BDEPEND="
- >=dev-go/go-md2man-2.0.2
+ >=dev-go/go-md2man-2.0.3
"
src_prepare() {